aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-07-31 21:17:32 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-07-31 21:19:37 +0000
commit577873f6aa8f2675b90e950bd03535948e2e4cd6 (patch)
tree207e78e1ada6cc62e68571f3465449f04080ae3d
parent2f7a6aed9be0c50c3dce2bc15336af4e1a8d10aa (diff)
downloadports-577873f6aa8f2675b90e950bd03535948e2e4cd6.tar.gz
ports-577873f6aa8f2675b90e950bd03535948e2e4cd6.zip
math/topcom: Add option SOPLEX
It fixes build in the presence of the SoPlex package. Reported by: Philipp Ost <bsd@philippost.de>
-rw-r--r--math/topcom/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/math/topcom/Makefile b/math/topcom/Makefile
index 8f9fee7af2ff..72d403737fd7 100644
--- a/math/topcom/Makefile
+++ b/math/topcom/Makefile
@@ -1,5 +1,6 @@
PORTNAME= topcom
DISTVERSION= 0.17.8
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://www.rambau.wm.uni-bayreuth.de/Software/
DISTNAME= ${PORTNAME:tu}-${DISTVERSION}
@@ -21,6 +22,13 @@ LDFLAGS+= -lgmp -lgmpxx -lcddgmp
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
+OPTIONS_DEFINE= SOPLEX # SOPLEX shouldn't be made default because SoPlex's license prevents packaging.
+
+SOPLEX_DESC= Build with SoPlex linear programming problem solver
+SOPLEX_CXXFLAGS= -I${LOCALBASE}/include/soplex
+SOPLEX_LIB_DEPENDS= libsoplex.so:math/SoPlex
+SOPLEX_BROKEN= not compatible with SoPlex-5.0.2 - missing header, reported to the upstream author vie e-mail
+
post-extract:
@${RM} -r ${WRKSRC}/external
@@ -31,4 +39,7 @@ post-patch:
s|\.\./external/lib/libgmp\.a|${LOCALBASE}/lib/libgmp.so| ; \
s|\.\./external/lib/libgmpxx\.a|${LOCALBASE}/lib/libgmpxx.so|'
+post-patch-SOPLEX-off:
+ @${REINPLACE_CMD} -e 's|AC_CHECK_LIB(soplex,|AC_CHECK_LIB(soplex_disabled,|' ${WRKSRC}/configure.ac
+
.include <bsd.port.mk>