aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2021-07-23 00:41:47 +0000
committerSteve Wills <swills@FreeBSD.org>2021-08-28 01:45:42 +0000
commit57a3995a942c59fa51caa39552b290243e957613 (patch)
tree8cea8bfd866c527434edffe7988d0f040c68eb79
parentb16616b283a7564fbd6a001b47decd2d89fcc5c5 (diff)
downloadports-57a3995a942c59fa51caa39552b290243e957613.tar.gz
ports-57a3995a942c59fa51caa39552b290243e957613.zip
net/syncthing: update to 1.18.1 [0]
While here, work around multicast issue until all supported versions have the fix [1] PR: 257322 [1] Obtained from: Alex Vasylenko <lxv@omut.org> [1]
-rw-r--r--net/syncthing/Makefile2
-rw-r--r--net/syncthing/distinfo6
-rw-r--r--net/syncthing/files/patch-syncthing_lib_beacon_multicast.go12
3 files changed, 16 insertions, 4 deletions
diff --git a/net/syncthing/Makefile b/net/syncthing/Makefile
index e173aebafdcf..926f248e434c 100644
--- a/net/syncthing/Makefile
+++ b/net/syncthing/Makefile
@@ -1,5 +1,5 @@
PORTNAME= syncthing
-PORTVERSION= 1.18.0
+PORTVERSION= 1.18.1
DISTVERSIONPREFIX= v
CATEGORIES= net
MASTER_SITES= https://github.com/syncthing/syncthing/releases/download/v${PORTVERSION}/
diff --git a/net/syncthing/distinfo b/net/syncthing/distinfo
index 796287005e7c..019a94a64441 100644
--- a/net/syncthing/distinfo
+++ b/net/syncthing/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1626354379
-SHA256 (syncthing-source-v1.18.0.tar.gz) = 169d3579b74083d4115b4d324620a7f0888e4b1a3ad3dac71d46d76d51322900
-SIZE (syncthing-source-v1.18.0.tar.gz) = 12856546
+TIMESTAMP = 1630113856
+SHA256 (syncthing-source-v1.18.1.tar.gz) = 3f6b8e87a59e72ab3389d89364524e6abec454d4c36aaf3e334ac6fe37915584
+SIZE (syncthing-source-v1.18.1.tar.gz) = 12860998
diff --git a/net/syncthing/files/patch-syncthing_lib_beacon_multicast.go b/net/syncthing/files/patch-syncthing_lib_beacon_multicast.go
new file mode 100644
index 000000000000..2b817687cf6e
--- /dev/null
+++ b/net/syncthing/files/patch-syncthing_lib_beacon_multicast.go
@@ -0,0 +1,12 @@
+--- syncthing/lib/beacon/multicast.go.orig 2021-07-06 12:51:32 UTC
++++ syncthing/lib/beacon/multicast.go
+@@ -126,6 +126,9 @@ func readMulticasts(ctx context.Context, outbox chan<-
+ pconn := ipv6.NewPacketConn(conn)
+ joined := 0
+ for _, intf := range intfs {
++ if intf.Flags&net.FlagUp == 0 || intf.Flags&net.FlagMulticast == 0 || intf.Name == "ipfw0" {
++ continue
++ }
+ err := pconn.JoinGroup(&intf, &net.UDPAddr{IP: gaddr.IP})
+ if err != nil {
+ l.Debugln("IPv6 join", intf.Name, "failed:", err)