aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2023-08-09 18:43:31 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2023-08-09 18:43:31 +0000
commit57acd564071bd0f5a690bbe6fd8e6451b8325d00 (patch)
tree08d3b5e1b9db3c6fdc44d3a622a27431474b3969
parent4157e9fcedc8859616080d72972b6163e2a94c9a (diff)
downloadports-57acd564071bd0f5a690bbe6fd8e6451b8325d00.tar.gz
ports-57acd564071bd0f5a690bbe6fd8e6451b8325d00.zip
security/git-credential-azure: Add new port
git-credential-azure is a Git credential helper that authenticates to Azure Repos (dev.azure.com). Azure Repos is part of Azure DevOps. The first time you authenticate, the helper opens a browser window to Microsoft login. Subsequent authentication is non interactive.
-rw-r--r--security/Makefile3
-rw-r--r--security/git-credential-azure/Makefile21
-rw-r--r--security/git-credential-azure/distinfo7
-rw-r--r--security/git-credential-azure/pkg-descr5
4 files changed, 35 insertions, 1 deletions
diff --git a/security/Makefile b/security/Makefile
index cda821d223e4..615e9405bebe 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -171,6 +171,7 @@
SUBDIR += fwlogwatch
SUBDIR += gcr
SUBDIR += gef
+ SUBDIR += git-credential-azure
SUBDIR += git-credential-gopass
SUBDIR += git-credential-oauth
SUBDIR += git-crypt
@@ -1281,11 +1282,11 @@
SUBDIR += stoken
SUBDIR += strongswan
SUBDIR += stunnel
+ SUBDIR += su-exec
SUBDIR += subversion-gnome-keyring
SUBDIR += sudo
SUBDIR += sudoscript
SUBDIR += super
- SUBDIR += su-exec
SUBDIR += suricata
SUBDIR += swatchdog
SUBDIR += tailscale
diff --git a/security/git-credential-azure/Makefile b/security/git-credential-azure/Makefile
new file mode 100644
index 000000000000..d3393f6e6641
--- /dev/null
+++ b/security/git-credential-azure/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= git-credential-azure
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.1
+CATEGORIES= security
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Git credential helper for Azure Repos
+WWW= https://github.com/hickford/git-credential-azure
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= go:modules
+USE_GITHUB= yes
+GH_ACCOUNT= hickford
+
+GO_MODULE= github.com/${GH_ACCOUNT}/${PORTNAME}
+
+PLIST_FILES= bin/git-credential-azure
+
+.include <bsd.port.mk>
diff --git a/security/git-credential-azure/distinfo b/security/git-credential-azure/distinfo
new file mode 100644
index 000000000000..b1543d124b65
--- /dev/null
+++ b/security/git-credential-azure/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1691397569
+SHA256 (go/security_git-credential-azure/hickford-git-credential-azure-v0.2.1_GH0/v0.2.1.mod) = 3d207d8260274ff29fa4bc994761db4eb9e53ee38bf27cfd57c9cdb8332f797a
+SIZE (go/security_git-credential-azure/hickford-git-credential-azure-v0.2.1_GH0/v0.2.1.mod) = 395
+SHA256 (go/security_git-credential-azure/hickford-git-credential-azure-v0.2.1_GH0/v0.2.1.zip) = 9418ab4b310fe00dd2b4b809df0d05b3a64fbba24b41efabbb3f64db60ceab75
+SIZE (go/security_git-credential-azure/hickford-git-credential-azure-v0.2.1_GH0/v0.2.1.zip) = 10237
+SHA256 (go/security_git-credential-azure/hickford-git-credential-azure-v0.2.1_GH0/hickford-git-credential-azure-v0.2.1_GH0.tar.gz) = f3a05c73d03b0e5e58a9cd88275422a6b4b5e2ef75fd193b0f1c972e663c96a1
+SIZE (go/security_git-credential-azure/hickford-git-credential-azure-v0.2.1_GH0/hickford-git-credential-azure-v0.2.1_GH0.tar.gz) = 8448
diff --git a/security/git-credential-azure/pkg-descr b/security/git-credential-azure/pkg-descr
new file mode 100644
index 000000000000..b8d093afb868
--- /dev/null
+++ b/security/git-credential-azure/pkg-descr
@@ -0,0 +1,5 @@
+git-credential-azure is a Git credential helper that authenticates to
+Azure Repos (dev.azure.com). Azure Repos is part of Azure DevOps.
+
+The first time you authenticate, the helper opens a browser window to
+Microsoft login. Subsequent authentication is non interactive.