aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2022-12-22 20:11:44 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2022-12-22 20:11:44 +0000
commit587f13705ee5cd3e9a298dd8dbea92fe03420724 (patch)
tree62a3083363fdb194a60811abf8d5d212082f1361
parent6f4d5e781851d25c97c030465702aa5ce25baf02 (diff)
downloadports-587f13705ee5cd3e9a298dd8dbea92fe03420724.tar.gz
ports-587f13705ee5cd3e9a298dd8dbea92fe03420724.zip
net/ntopng: Update to latest upstream satable snapshot
- Import one patch from upstream head fixing a bug in stable branch [1] Obtained from: https://github.com/ntop/ntopng/commit/9d7bdc36a0d9cf7f06fd66f1ee26d7bb79c7c109 [1]
-rw-r--r--net/ntopng/Makefile6
-rw-r--r--net/ntopng/distinfo10
-rw-r--r--net/ntopng/files/patch-FlowDevicesFix41
3 files changed, 49 insertions, 8 deletions
diff --git a/net/ntopng/Makefile b/net/ntopng/Makefile
index 2879d75de5c1..961f42ec6192 100644
--- a/net/ntopng/Makefile
+++ b/net/ntopng/Makefile
@@ -1,5 +1,5 @@
PORTNAME= ntopng
-PORTVERSION= 5.4.d20220812
+PORTVERSION= 5.4.d20221219
PORTEPOCH= 1
CATEGORIES= net
@@ -39,9 +39,9 @@ GROUPS= ntopng
PLIST_SUB= NTOPNGUSER="${USERS}" NTOPNGROUP="${GROUPS}"
USE_GITHUB= yes
-GH_TUPLE= ntop:ntopng-dist:604aa39:dist/httpdocs/dist
+GH_TUPLE= ntop:ntopng-dist:9579bab:dist/httpdocs/dist
GH_ACCOUNT= ntop
-GH_TAGNAME= 8ade112
+GH_TAGNAME= 05f68a1
CPE_VENDOR= ntop
diff --git a/net/ntopng/distinfo b/net/ntopng/distinfo
index cf4dff247765..a75d33fd591f 100644
--- a/net/ntopng/distinfo
+++ b/net/ntopng/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1660757495
-SHA256 (ntop-ntopng-5.4.d20220812-8ade112_GH0.tar.gz) = a6e37f51dc1406322beb4c9998215422bc69b653c054340fd9d6e307648bf138
-SIZE (ntop-ntopng-5.4.d20220812-8ade112_GH0.tar.gz) = 42662190
-SHA256 (ntop-ntopng-dist-604aa39_GH0.tar.gz) = 0187ee0514ec63e4421e8386f521cf241d6b72da9683ef2bd164851deb6e2d87
-SIZE (ntop-ntopng-dist-604aa39_GH0.tar.gz) = 1712437
+TIMESTAMP = 1671612269
+SHA256 (ntop-ntopng-5.4.d20221219-05f68a1_GH0.tar.gz) = 762eed49add7c8125357a1c0e0304355abbb306854442ade71d93ed9ec129ee1
+SIZE (ntop-ntopng-5.4.d20221219-05f68a1_GH0.tar.gz) = 42663355
+SHA256 (ntop-ntopng-dist-9579bab_GH0.tar.gz) = 5108087df5ad60512d646909db5f63aceedd99c24ba0f8c594c4c88dba1a04dd
+SIZE (ntop-ntopng-dist-9579bab_GH0.tar.gz) = 1712425
diff --git a/net/ntopng/files/patch-FlowDevicesFix b/net/ntopng/files/patch-FlowDevicesFix
new file mode 100644
index 000000000000..55a058a54355
--- /dev/null
+++ b/net/ntopng/files/patch-FlowDevicesFix
@@ -0,0 +1,41 @@
+From 9d7bdc36a0d9cf7f06fd66f1ee26d7bb79c7c109 Mon Sep 17 00:00:00 2001
+From: Luca Deri <deri@ntop.org>
+Date: Mon, 12 Dec 2022 10:37:13 +0100
+Subject: [PATCH] Fixes #7029
+
+---
+ scripts/lua/inc/menu.lua | 2 +-
+ src/LuaEngineInterface.cpp | 4 +++-
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/scripts/lua/inc/menu.lua b/scripts/lua/inc/menu.lua
+index 24bfbabd3b3..081c7729171 100644
+--- scripts/lua/inc/menu.lua
++++ scripts/lua/inc/menu.lua
+@@ -305,7 +305,7 @@ else
+
+ -- Exporters
+
+- local has_exporters = (ifs.type == "zmq") or (ifs.type == "custom") or (table.len(interface.getFlowDevices()) > 0)
++ local has_exporters = (ifs.type == "zmq") or (ifs.type == "custom") or (ntop.isPro() and (table.len(interface.getFlowDevices()) > 0))
+
+ page_utils.add_menubar_section(
+ {
+diff --git a/src/LuaEngineInterface.cpp b/src/LuaEngineInterface.cpp
+index fa1cc582fa1..9dfc147effd 100644
+--- src/LuaEngineInterface.cpp
++++ src/LuaEngineInterface.cpp
+@@ -4657,10 +4657,12 @@ static luaL_Reg _ntop_interface_reg[] = {
+ /* SNMP */
+ { "getSNMPStats", ntop_interface_get_snmp_stats },
+
++#ifdef NTOPNG_PRO
+ /* Flow Devices */
+ { "getFlowDevices", ntop_get_flow_devices },
+ { "getFlowDeviceInfo", ntop_get_flow_device_info },
+-
++#endif
++
+ #ifdef HAVE_NEDGE
+ /* L7 */
+ { "reloadL7Rules", ntop_reload_l7_rules },