aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-16 13:58:43 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-16 13:58:43 +0000
commit58a791d95ee7046bc23e1741cef4e8498ba3ac2c (patch)
tree756feca615f3d03d1edfd0b0da3e2f01f1d383ac
parent9004702831f4f77158831fa63c9ce450ae919722 (diff)
downloadports-58a791d95ee7046bc23e1741cef4e8498ba3ac2c.tar.gz
ports-58a791d95ee7046bc23e1741cef4e8498ba3ac2c.zip
devel/py-pytest-nunit: Add py-pytest-nunit 1.0.0
pytest-nunit is a pytest plugin for generating NUnit3 test result XML output. WWW: https://github.com/pytest-dev/pytest-nunit
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytest-nunit/Makefile23
-rw-r--r--devel/py-pytest-nunit/distinfo3
-rw-r--r--devel/py-pytest-nunit/pkg-descr3
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b2869c5d586e..6f2545b0a0b0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5150,6 +5150,7 @@
SUBDIR += py-pytest-mock
SUBDIR += py-pytest-mutagen
SUBDIR += py-pytest-mypy
+ SUBDIR += py-pytest-nunit
SUBDIR += py-pytest-pep8
SUBDIR += py-pytest-plus
SUBDIR += py-pytest-pycodestyle
diff --git a/devel/py-pytest-nunit/Makefile b/devel/py-pytest-nunit/Makefile
new file mode 100644
index 000000000000..4606fe02af6f
--- /dev/null
+++ b/devel/py-pytest-nunit/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= pytest-nunit
+PORTVERSION= 1.0.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= pytest plugin for generating NUnit3 test result XML output
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}attrs>=0:devel/py-attrs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=4.6.0,1:devel/py-pytest@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytest-nunit/distinfo b/devel/py-pytest-nunit/distinfo
new file mode 100644
index 000000000000..5957abf0699f
--- /dev/null
+++ b/devel/py-pytest-nunit/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1655208192
+SHA256 (pytest-nunit-1.0.0.tar.gz) = 3c3e7a5396d0c3910c043d2d9aa4085777b21183d993e09b24411efb276aa10b
+SIZE (pytest-nunit-1.0.0.tar.gz) = 16442
diff --git a/devel/py-pytest-nunit/pkg-descr b/devel/py-pytest-nunit/pkg-descr
new file mode 100644
index 000000000000..e6071aa69bad
--- /dev/null
+++ b/devel/py-pytest-nunit/pkg-descr
@@ -0,0 +1,3 @@
+pytest-nunit is a pytest plugin for generating NUnit3 test result XML output.
+
+WWW: https://github.com/pytest-dev/pytest-nunit