aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-06-16 15:55:43 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-06-16 15:56:40 +0000
commit58ba468f234ddf4c807da14ed36e0359c39ba92e (patch)
tree27676abe9bd0baf9bca7919aa20ba0b74381fd3d
parent8223bcd1205390f4dc904b2245e9cfce631d7800 (diff)
downloadports-58ba468f234ddf4c807da14ed36e0359c39ba92e.tar.gz
ports-58ba468f234ddf4c807da14ed36e0359c39ba92e.zip
devel/bazel: properly add the abseil patch
In file included from external/com_google_absl/absl/base/internal/unscaledcycleclock.cc:27: /usr/include/sys/sysctl.h:1185:25: error: unknown type name 'u_int' int sysctl(const int *, u_int, void *, size_t *, const void *, size_t); ^ external/com_google_absl/absl/base/internal/unscaledcycleclock.cc:95:10: error: unknown type name 'once_flag' static once_flag init_timebase_frequency_once; ^ external/com_google_absl/absl/base/internal/unscaledcycleclock.cc:97:18: error: no member named 'LowLevelCallOnce' in namespace 'absl::base_internal' base_internal::LowLevelCallOnce(&init_timebase_frequency_once, [&]() { ~~~~~~~~~~~~~~~^ 3 errors generated.
-rw-r--r--devel/bazel/Makefile3
-rw-r--r--devel/bazel/files/patch-distdir_deps.bzl14
2 files changed, 14 insertions, 3 deletions
diff --git a/devel/bazel/Makefile b/devel/bazel/Makefile
index 609e74343437..95ecf6cfbdf6 100644
--- a/devel/bazel/Makefile
+++ b/devel/bazel/Makefile
@@ -56,7 +56,8 @@ BAZEL_JAVAC_OPTS+= "-J-Xmx1g -J-Xms128m"
pre-patch:
@${CP} ${FILESDIR}/extra-patch-absl_base_internal_unscaledcycleclock.cc \
- ${FILESDIR}/extra-patch-bazel_grpc__deps.bzl \
+ ${WRKSRC}/third_party/py/abseil/
+ @${CP} ${FILESDIR}/extra-patch-bazel_grpc__deps.bzl \
${FILESDIR}/extra-patch-bazel_build_defs.bzl \
${WRKSRC}/third_party/grpc/
diff --git a/devel/bazel/files/patch-distdir_deps.bzl b/devel/bazel/files/patch-distdir_deps.bzl
index 1a91f6c030a7..7585e5a1fe7b 100644
--- a/devel/bazel/files/patch-distdir_deps.bzl
+++ b/devel/bazel/files/patch-distdir_deps.bzl
@@ -1,10 +1,20 @@
---- distdir_deps.bzl.orig 1980-01-01 00:00:00 UTC
+--- distdir_deps.bzl.orig 1979-12-31 23:00:00 UTC
+++ distdir_deps.bzl
@@ -130,6 +130,7 @@ DIST_DEPS = {
"patch_args": ["-p1"],
"patches": [
"//third_party/grpc:grpc_1.41.0.patch",
-+ "//third_party/grpc:extra-patch-bazel_grpc__deps.bzl",
++ "//third_party/grpc:extra-patch-bazel_grpc__deps.bzl",
"//third_party/grpc:grpc_1.41.0.win_arm64.patch",
],
"used_in": [
+@@ -168,6 +169,9 @@ DIST_DEPS = {
+ "https://mirror.bazel.build/github.com/abseil/abseil-cpp/archive/refs/tags/20211102.0.tar.gz",
+ "https://github.com/abseil/abseil-cpp/archive/refs/tags/20211102.0.tar.gz",
+ ],
++ "patches": [
++ "//third_party/py/abseil:extra-patch-absl_base_internal_unscaledcycleclock.cc",
++ ],
+ "used_in": [
+ "additional_distfiles",
+ "test_WORKSPACE_files",