aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2021-06-25 17:54:07 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2021-06-25 17:54:07 +0000
commit5953db5520dafbf28b3b2e46d1cc62f0a01706f2 (patch)
treecf2d1d49f62be454e6679234d557017430a8c66b
parent3716d1981fdda9fc12b323079093d0b6aaa6fcf2 (diff)
downloadports-5953db5520dafbf28b3b2e46d1cc62f0a01706f2.tar.gz
ports-5953db5520dafbf28b3b2e46d1cc62f0a01706f2.zip
www/unit*: fix syntax error
-rw-r--r--www/unit-perl/Makefile5
-rw-r--r--www/unit/Makefile7
2 files changed, 7 insertions, 5 deletions
diff --git a/www/unit-perl/Makefile b/www/unit-perl/Makefile
index 526a7fed4bb8..725afb62fefb 100644
--- a/www/unit-perl/Makefile
+++ b/www/unit-perl/Makefile
@@ -16,11 +16,6 @@ USE_RC_SUBR?= # reset to empty
MASTERDIR= ${.CURDIR}/../unit
-# Fix build failure on clang12
-.if ${OSVERSION} >= 1400023
-CFLAGS+= -Wno-compound-token-split-by-macro
-.endif
-
post-configure:
cd ${CONFIGURE_WRKSRC} && \
${CONFIGURE_CMD} perl --module=${UNIT_MODNAME}
diff --git a/www/unit/Makefile b/www/unit/Makefile
index a6f321c9e45a..8b80ce335356 100644
--- a/www/unit/Makefile
+++ b/www/unit/Makefile
@@ -106,6 +106,13 @@ CONFIGURE_ARGS+=--no-unix-sockets
CONFIGURE_ARGS+=--control=unix:${UNIT_SOCK}
.endif
+.if defined(UNIT_MODNAME) && ${UNIT_MODNAME:Mperl*}
+# Fix build failure on clang12
+.if ${OSVERSION} >= 1400023
+CFLAGS+= -Wno-compound-token-split-by-macro
+.endif
+.endif
+
.if !target(post-install)
post-install:
${MKDIR} ${STAGEDIR}${UNIT_DBDIR}