aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2023-04-03 14:14:33 +0000
committerGleb Popov <arrowd@FreeBSD.org>2023-04-03 14:15:32 +0000
commit59702618d8959c53e9f9b1947b4844da374acc8a (patch)
tree260d3a3e45d6a6f6a5e62ca927d92db7e5fa4c04
parent93eaa5412bfca8daf12b7c81110c81b83211f54e (diff)
downloadports-59702618d8959c53e9f9b1947b4844da374acc8a.tar.gz
ports-59702618d8959c53e9f9b1947b4844da374acc8a.zip
ports-mgmt/packagekit-qt: Qt interface to the PackageKit daemon.
Sponsored by: Serenity Cybersecurity, LLC
-rw-r--r--ports-mgmt/Makefile1
-rw-r--r--ports-mgmt/packagekit-qt/Makefile22
-rw-r--r--ports-mgmt/packagekit-qt/distinfo3
-rw-r--r--ports-mgmt/packagekit-qt/pkg-descr3
-rw-r--r--ports-mgmt/packagekit-qt/pkg-plist19
5 files changed, 48 insertions, 0 deletions
diff --git a/ports-mgmt/Makefile b/ports-mgmt/Makefile
index e47afdfbd086..8f5a5aba30f0 100644
--- a/ports-mgmt/Makefile
+++ b/ports-mgmt/Makefile
@@ -21,6 +21,7 @@
SUBDIR += p5-FreeBSD-Ports
SUBDIR += p5-FreeBSD-Ports-INDEXhash
SUBDIR += packagekit
+ SUBDIR += packagekit-qt
SUBDIR += parfetch-overlay
SUBDIR += pchecker
SUBDIR += pkg
diff --git a/ports-mgmt/packagekit-qt/Makefile b/ports-mgmt/packagekit-qt/Makefile
new file mode 100644
index 000000000000..a7b47958411b
--- /dev/null
+++ b/ports-mgmt/packagekit-qt/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= PackageKit-Qt
+PORTVERSION= 1.1.1
+CATEGORIES= ports-mgmt sysutils
+MASTER_SITES= https://www.freedesktop.org/software/PackageKit/releases/
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= DBUS packaging abstraction layer (Qt bindings)
+WWW= https://www.freedesktop.org/software/PackageKit/
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${LOCALBASE}/share/dbus-1/interfaces/org.freedesktop.PackageKit.xml:ports-mgmt/packagekit
+
+USES= cmake cpe qt:5 tar:xz
+
+USE_QT= core dbus buildtools:build qmake:build
+USE_LDCONFIG= yes
+
+CPE_VENDOR= packagekit_project
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/packagekit-qt/distinfo b/ports-mgmt/packagekit-qt/distinfo
new file mode 100644
index 000000000000..d14e1a6e24e6
--- /dev/null
+++ b/ports-mgmt/packagekit-qt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1680525838
+SHA256 (PackageKit-Qt-1.1.1.tar.xz) = 8ad57523dbfd5a4b2086fa420b8ded63024e12efb8ca0ac42db767842e506212
+SIZE (PackageKit-Qt-1.1.1.tar.xz) = 46856
diff --git a/ports-mgmt/packagekit-qt/pkg-descr b/ports-mgmt/packagekit-qt/pkg-descr
new file mode 100644
index 000000000000..cb8700fb2d0e
--- /dev/null
+++ b/ports-mgmt/packagekit-qt/pkg-descr
@@ -0,0 +1,3 @@
+PackageKit is a DBUS abstraction layer that allows the session user to manage
+packages in a secure way using a cross-distro, cross-architecture API. This
+library provides Qt-styled API to PackageKit.
diff --git a/ports-mgmt/packagekit-qt/pkg-plist b/ports-mgmt/packagekit-qt/pkg-plist
new file mode 100644
index 000000000000..6e713e71e48e
--- /dev/null
+++ b/ports-mgmt/packagekit-qt/pkg-plist
@@ -0,0 +1,19 @@
+include/packagekitqt5/PackageKit/Daemon
+include/packagekitqt5/PackageKit/Details
+include/packagekitqt5/PackageKit/Offline
+include/packagekitqt5/PackageKit/Transaction
+include/packagekitqt5/PackageKit/bitfield.h
+include/packagekitqt5/PackageKit/common.h
+include/packagekitqt5/PackageKit/daemon.h
+include/packagekitqt5/PackageKit/details.h
+include/packagekitqt5/PackageKit/offline.h
+include/packagekitqt5/PackageKit/packagekitqt_global.h
+include/packagekitqt5/PackageKit/transaction.h
+lib/cmake/packagekitqt5/PackageKitQtTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/packagekitqt5/PackageKitQtTargets.cmake
+lib/cmake/packagekitqt5/packagekitqt5-config-version.cmake
+lib/cmake/packagekitqt5/packagekitqt5-config.cmake
+lib/libpackagekitqt5.so
+lib/libpackagekitqt5.so.1
+lib/libpackagekitqt5.so.1.1.1
+libdata/pkgconfig/packagekitqt5.pc