aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-01-11 16:57:12 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-01-11 18:43:53 +0000
commit5984fd68acf86116c516f4cb156c0ef9c944f682 (patch)
tree189c7fa471f7091b382eeae099549ff38e3c8cc2
parent1dd6f0ad9285c45d382252a83422e4f4625c755a (diff)
downloadports-5984fd68acf86116c516f4cb156c0ef9c944f682.tar.gz
ports-5984fd68acf86116c516f4cb156c0ef9c944f682.zip
www/rubygem-actioncable70: Add rubygem-actioncable70 7.0.0
Action Cable seamlessly integrates WebSockets with the rest of your Rails application. It allows for real-time features to be written in Ruby in the same style and form as the rest of your Rails application, while still being performant and scalable. It's a full-stack offering that provides both a client-side JavaScript framework and a server-side Ruby framework. You have access to your full domain model written with Active Record or your ORM of choice. WWW: https://rubyonrails.org/ WWW: https://github.com/rails/rails/tree/main/actioncable
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-actioncable70/Makefile27
-rw-r--r--www/rubygem-actioncable70/distinfo3
-rw-r--r--www/rubygem-actioncable70/pkg-descr10
4 files changed, 41 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f65defb33283..730fe3cd591f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1838,6 +1838,7 @@
SUBDIR += rubygem-actioncable52
SUBDIR += rubygem-actioncable60
SUBDIR += rubygem-actioncable61
+ SUBDIR += rubygem-actioncable70
SUBDIR += rubygem-actionpack4
SUBDIR += rubygem-actionpack5
SUBDIR += rubygem-actionpack50
diff --git a/www/rubygem-actioncable70/Makefile b/www/rubygem-actioncable70/Makefile
new file mode 100644
index 000000000000..1c592e9e0517
--- /dev/null
+++ b/www/rubygem-actioncable70/Makefile
@@ -0,0 +1,27 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= actioncable
+PORTVERSION= 7.0.0
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 70
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Structure many real-time application concerns into channels over a single WebSocket connection
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-actionpack70>=${PORTVERSION}:www/rubygem-actionpack70 \
+ rubygem-activesupport70>=${PORTVERSION}:devel/rubygem-activesupport70 \
+ rubygem-nio4r>=2.0<3:devel/rubygem-nio4r \
+ rubygem-websocket-driver>=0.6.1:www/rubygem-websocket-driver
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^7\.0\.
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-actioncable70/distinfo b/www/rubygem-actioncable70/distinfo
new file mode 100644
index 000000000000..90cd723b2e7e
--- /dev/null
+++ b/www/rubygem-actioncable70/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1641045772
+SHA256 (rubygem/actioncable-7.0.0.gem) = 04811040d3b4baea7c7f0e95bb3a32e72d26ea0931b9ef3444829b28f9ccec0a
+SIZE (rubygem/actioncable-7.0.0.gem) = 44032
diff --git a/www/rubygem-actioncable70/pkg-descr b/www/rubygem-actioncable70/pkg-descr
new file mode 100644
index 000000000000..5b56556ed173
--- /dev/null
+++ b/www/rubygem-actioncable70/pkg-descr
@@ -0,0 +1,10 @@
+Action Cable seamlessly integrates WebSockets with the rest of your Rails
+application. It allows for real-time features to be written in Ruby in the same
+style and form as the rest of your Rails application, while still being
+performant and scalable. It's a full-stack offering that provides both a
+client-side JavaScript framework and a server-side Ruby framework. You have
+access to your full domain model written with Active Record or your ORM of
+choice.
+
+WWW: https://rubyonrails.org/
+WWW: https://github.com/rails/rails/tree/main/actioncable