aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJuraj Lutter <otis@FreeBSD.org>2021-11-08 14:19:17 +0000
committerJuraj Lutter <otis@FreeBSD.org>2021-11-08 22:51:03 +0000
commit59a769411020534e2384d277b50368033764ab2f (patch)
tree945cfa548a27bb8b2d8fbd6ead8fe491c68f5c42
parent9e183afca660a085d9c5ee615cc5a9655f21ef9f (diff)
downloadports-59a769411020534e2384d277b50368033764ab2f.tar.gz
ports-59a769411020534e2384d277b50368033764ab2f.zip
mail/postfix-current: Update to
- Update to 3.7-20211030 - Clean up Makefile a bit - Changelog: http://cdn.postfix.johnriley.me/mirrors/postfix-release/experimental/postfix-3.7-20211030.HISTORY
-rw-r--r--mail/postfix-current/Makefile45
-rw-r--r--mail/postfix-current/distinfo6
2 files changed, 33 insertions, 18 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index 13965077086d..e2b242c7a5be 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -1,7 +1,7 @@
# Created by: Torsten Blum <torstenb@FreeBSD.org>
PORTNAME= postfix
-DISTVERSION= 3.7-20211023
+DISTVERSION= 3.7-20211030
PORTREVISION?= 0
PORTEPOCH= 6
CATEGORIES= mail
@@ -166,7 +166,21 @@ SUB_LIST+= DAEMONDIR="${DAEMONDIR}" \
REQUIRE="${_REQUIRE}"
SUB_FILES+= mailer.conf.postfix pkg-install pkg-message
-POSTFIX_CCARGS+= -DDEF_CONFIG_DIR=\\\"${ETCDIR}\\\" -DDEF_DAEMON_DIR=\\\"${DAEMONDIR}\\\" -DDEF_META_DIR=\\\"${META_DIRECTORY}\\\" -DDEF_COMMAND_DIR=\\\"${PREFIX}/sbin\\\" -DDEF_SENDMAIL_PATH=\\\"${PREFIX}/sbin/sendmail\\\" -DDEF_NEWALIAS_PATH=\\\"${PREFIX}/bin/newaliases\\\" -DDEF_MAILQ_PATH=\\\"${PREFIX}/bin/mailq\\\" -DDEF_MANPAGE_DIR=\\\"${MANPREFIX}/man\\\" -DDEF_README_DIR=\\\"${READMEDIR}\\\" -DDEF_HTML_DIR=\\\"${READMEDIR}\\\" -DDEF_QUEUE_DIR=\\\"/var/spool/postfix\\\" -DDEF_DATA_DIR=\\\"/var/db/postfix\\\" -DDEF_MAIL_OWNER=\\\"postfix\\\" -DDEF_SGID_GROUP=\\\"maildrop\\\" -Wmissing-prototypes -Wformat -Wno-comment
+POSTFIX_CCARGS+= -DDEF_CONFIG_DIR=\\\"${ETCDIR}\\\" \
+ -DDEF_DAEMON_DIR=\\\"${DAEMONDIR}\\\" \
+ -DDEF_META_DIR=\\\"${META_DIRECTORY}\\\" \
+ -DDEF_COMMAND_DIR=\\\"${PREFIX}/sbin\\\" \
+ -DDEF_SENDMAIL_PATH=\\\"${PREFIX}/sbin/sendmail\\\" \
+ -DDEF_NEWALIAS_PATH=\\\"${PREFIX}/bin/newaliases\\\" \
+ -DDEF_MAILQ_PATH=\\\"${PREFIX}/bin/mailq\\\" \
+ -DDEF_MANPAGE_DIR=\\\"${MANPREFIX}/man\\\" \
+ -DDEF_README_DIR=\\\"${READMEDIR}\\\" \
+ -DDEF_HTML_DIR=\\\"${READMEDIR}\\\" \
+ -DDEF_QUEUE_DIR=\\\"/var/spool/postfix\\\" \
+ -DDEF_DATA_DIR=\\\"/var/db/postfix\\\" \
+ -DDEF_MAIL_OWNER=\\\"postfix\\\" \
+ -DDEF_SGID_GROUP=\\\"maildrop\\\" \
+ -Wmissing-prototypes -Wformat -Wno-comment
# Default requirement for postfix rc script
_REQUIRE= LOGIN cleanvar dovecot
@@ -284,19 +298,20 @@ POSTFIX_DYN_AUXLIBS+= "AUXLIBS_LMDB=-L${LOCALBASE}/lib -llmdb"
.endif
# sed script for files in ${WRKSRC}/README_FILES ${WRKSRC}/conf ${WRKSRC}/man
-REINPLACE= s!^PATH=.*!PATH=/bin:/sbin:/usr/bin:/usr/sbin:${PREFIX}/bin:${PREFIX}/sbin!; \
- s!(_directory = )/usr/!\1${PREFIX}/!g; s!^(data_directory = \
- /var/)lib/!\1db/!g; s!^\#(mynetworks_style = host)!\1!g; \
- s!^(sendmail_path =)!\1 ${PREFIX}/sbin/sendmail!g; \
- s!^(newaliases_path =)!\1 ${PREFIX}/bin/newaliases!g; \
- s!^(mailq_path =)!\1 ${PREFIX}/bin/mailq!g; s!^(setgid_group \
- =)!\1 maildrop!g; s!^(manpage_directory =)!\1 \
- ${MANPREFIX}/man!g; s!^((html|readme)_directory =)!\1 \
- ${READMEDIR}!g; \!^\#alias_database = \
- dbm:/etc/mail/aliases$$!d; s!(:|= \
- )/etc/postfix!\1$$config_directory!g; \
- s!/etc/postfix!${ETCDIR}!g; s!^(sample_directory =)!\1 \
- ${ETCDIR}!g; \
+REINPLACE= s!^PATH=.*!PATH=/bin:/sbin:/usr/bin:/usr/sbin:${PREFIX}/bin:${PREFIX}/sbin!;\
+ s!(_directory = )/usr/!\1${PREFIX}/!g;\
+ s!^(data_directory = /var/)lib/!\1db/!g;\
+ s!^\#(mynetworks_style = host)!\1!g;\
+ s!^(sendmail_path =)!\1 ${PREFIX}/sbin/sendmail!g;\
+ s!^(newaliases_path =)!\1 ${PREFIX}/bin/newaliases!g;\
+ s!^(mailq_path =)!\1 ${PREFIX}/bin/mailq!g;\
+ s!^(setgid_group =)!\1 maildrop!g;\
+ s!^(manpage_directory =)!\1 ${MANPREFIX}/man!g;\
+ s!^((html|readme)_directory =)!\1 ${READMEDIR}!g;\
+ \!^\#alias_database = dbm:/etc/mail/aliases$$!d;\
+ s!(:|= )/etc/postfix!\1$$config_directory!g;\
+ s!/etc/postfix!${ETCDIR}!g;\
+ s!^(sample_directory =)!\1 ${ETCDIR}!g; \
s!($$config_directory/(access|aliases|canonical|generic|header_checks|relocated|transport|virtual):f:root:-:644:)p1!\1o!;
pre-patch:
diff --git a/mail/postfix-current/distinfo b/mail/postfix-current/distinfo
index 7fbfc1c1b3a1..8f6df862f7d7 100644
--- a/mail/postfix-current/distinfo
+++ b/mail/postfix-current/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1635598846
-SHA256 (postfix/postfix-3.7-20211023.tar.gz) = 21c51b19175ba4ac663a4f82b5276b1fb4b011c57f7842df39cd96411b49bb14
-SIZE (postfix/postfix-3.7-20211023.tar.gz) = 4768047
+TIMESTAMP = 1636380916
+SHA256 (postfix/postfix-3.7-20211030.tar.gz) = a8a57c5e08d0ce591c7fef95f902210b2911467b0b75342fb6594603d7ca6858
+SIZE (postfix/postfix-3.7-20211030.tar.gz) = 4769363