aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-10-12 20:50:53 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-10-12 20:52:17 +0000
commit5a01079e224bafb6d19a74496fa78a0cb419eb46 (patch)
treea57f37b4fbe1368df76c1b5a9d732f74af42aae0
parentc4b16252b1c0bf38b7b57e3aa7761f450231c599 (diff)
downloadports-5a01079e224bafb6d19a74496fa78a0cb419eb46.tar.gz
ports-5a01079e224bafb6d19a74496fa78a0cb419eb46.zip
science/openmc: Unbreak LIBMESH option by switching to mpich
As it turned out LibMesh fails to compile with OpenMPI-{3,4}
-rw-r--r--science/openmc/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/science/openmc/Makefile b/science/openmc/Makefile
index 178c65250c23..3e719d598ae4 100644
--- a/science/openmc/Makefile
+++ b/science/openmc/Makefile
@@ -1,6 +1,7 @@
PORTNAME= openmc
DISTVERSIONPREFIX= v
DISTVERSION= 0.12.2
+PORTREVISION= 1
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
@@ -29,11 +30,10 @@ OPTIONS_DEFAULT= MPI OPENMP
LIBMESH_DESC= Support for libMesh unstructured mesh tallies
LIBMESH_CMAKE_BOOL= libmesh
LIBMESH_LIB_DEPENDS= libmesh_opt.so:math/libmesh
-LIBMESH_BROKEN= https://github.com/openmc-dev/openmc/issues/1893
-MPI_VARS= CXX=${LOCALBASE}/mpi/openmpi/bin/mpic++
-MPI_BUILD_DEPENDS= openmpi>0:net/openmpi
-MPI_RUN_DEPENDS= openmpi>0:net/openmpi
+MPI_VARS= CXX=${LOCALBASE}/bin/mpic++ # compilation breaks with OpenMPI-{3,4} and LIBMESH=ON
+MPI_BUILD_DEPENDS= mpich>0:net/mpich
+MPI_RUN_DEPENDS= mpich>0:net/mpich
OPENMP_CMAKE_BOOL= openmp