aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2023-05-09 15:26:00 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2023-05-12 15:39:47 +0000
commit5b4cadb23cbc2db23d7e2a40c16abd3e862fcf62 (patch)
tree5a3ca73ee1e293815c675b37106546f3270ed6ee
parent22530ba28be79b947e617dc1288896bfc3c6f6ef (diff)
downloadports-5b4cadb23cbc2db23d7e2a40c16abd3e862fcf62.tar.gz
ports-5b4cadb23cbc2db23d7e2a40c16abd3e862fcf62.zip
lang/gcc12: Work around aarch64 extraction bug
Extraction fails with poudriere on aarch64 with the following error: => SHA256 Checksum OK for gcc-12.2.0.tar.xz. tar: Pathname can't be converted from UTF-8 to current locale. tar: Pathname can't be converted from UTF-8 to current locale. tar: Error exit delayed from previous errors. Enforcing use of bsdtar works around the issue. The issue is specific to lang/gcc11 and lang/gcc12: no other GCC port is affected. See also bug https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=246670. PR: 271052 Reported by: Vidar Karlsen <vidar@karlsen.tech> Reviewed by: gerald, mikael
-rw-r--r--lang/gcc12/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/lang/gcc12/Makefile b/lang/gcc12/Makefile
index 56ade38b3832..1604c7fcfec8 100644
--- a/lang/gcc12/Makefile
+++ b/lang/gcc12/Makefile
@@ -62,6 +62,15 @@ CONFIGURE_ARGS+= --disable-multilib
.include <bsd.port.pre.mk>
+# Extraction fails with poudriere on aarch64 for GCC 12.
+# It seems that the bug is specific to lang/gcc11 and lang/gcc12 only.
+# No other GCC port is affected.
+# See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=271052
+# and https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=246670
+.if ${ARCH} == aarch64
+EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
+.endif
+
.if ${ARCH} == amd64
CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}