aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2023-03-29 13:59:27 +0000
committerCharlie Li <vishwin@FreeBSD.org>2023-03-29 13:59:27 +0000
commit5c98df76a3237ae0708819837f54f34fd3b04abf (patch)
tree54a0ee5dac8ada910b4bb1dcdbca863018ea1c08
parentc86338ba4fa0da1d5ed16f8f2cffd5d3b9e70e60 (diff)
downloadports-5c98df76a3237ae0708819837f54f34fd3b04abf.tar.gz
ports-5c98df76a3237ae0708819837f54f34fd3b04abf.zip
graphics/py-moderngl: explicitly add setuptools to BUILD_DEPENDS
PR: 270243
-rw-r--r--graphics/py-moderngl/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/graphics/py-moderngl/Makefile b/graphics/py-moderngl/Makefile
index fcb2550ccd21..447e389cdf37 100644
--- a/graphics/py-moderngl/Makefile
+++ b/graphics/py-moderngl/Makefile
@@ -11,7 +11,8 @@ WWW= https://moderngl.readthedocs.io/en/latest/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}glcontext>=2.3.6<3:graphics/py-glcontext@${PY_FLAVOR}
TEST_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>=1.2.1:science/py-scipy@${PY_FLAVOR}