aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-09-29 21:49:51 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-09-29 23:20:54 +0000
commit5ca2270159bada613f5c48cd1f3b666db0a72841 (patch)
tree564a0dcf0ceec821108e619eabd6b726fd854eb7
parent265d0864ce640fb30727b4e2174f517a71a3649e (diff)
downloadports-5ca2270159bada613f5c48cd1f3b666db0a72841.tar.gz
ports-5ca2270159bada613f5c48cd1f3b666db0a72841.zip
graphics/opendx: Remove CC/CPP/CXX exports
USES=llvm now by default exports CC/CPP/CXX so remove those Approved by: portmgr (blanket)
-rw-r--r--graphics/opendx/Makefile3
1 files changed, 0 insertions, 3 deletions
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index dde4473f5487..32f0bb43e5f8 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -74,9 +74,6 @@ PLIST_SUB+= UNAMEP=${ARCH}
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
USES+= llvm:max=15
-CC= clang${LLVM_VERSION}
-CPP= clang-cpp${LLVM_VERSION}
-CXX= clang++${LLVM_VERSION}
CONFIGURE_ENV+= ac_cv_requires_lstdcxx=yes
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif