aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeith Chiem <keith.chiem@gmail.com>2023-09-24 17:16:28 +0000
committerDries Michiels <driesm@FreeBSD.org>2023-09-24 17:24:33 +0000
commit5cf4242d5f468f1663da0df17f0b18b6edd6f581 (patch)
tree859abfcf4abf28709882577771d82d54dedea2be
parent6c696ba462f0fe954461370f664888f9ddaeb61c (diff)
downloadports-5cf4242d5f468f1663da0df17f0b18b6edd6f581.tar.gz
ports-5cf4242d5f468f1663da0df17f0b18b6edd6f581.zip
.NET ports: improve IPv6 detection in rc script
An IPv6 address on the localhost does not mean a jail has IPv6. Also remove two credit lines as he is now credited in the git log. PR: 273542 Reported by: michiel@vanbaak.eu Approved by: michiel@vanbaak.eu (maintainer)
-rw-r--r--multimedia/emby-server-devel/Makefile2
-rw-r--r--multimedia/emby-server/Makefile2
-rw-r--r--multimedia/emby-server/files/emby-server.in2
-rw-r--r--multimedia/jellyfin/Makefile2
-rwxr-xr-xmultimedia/jellyfin/files/jellyfin.in2
-rw-r--r--net-p2p/lidarr/Makefile1
-rw-r--r--net-p2p/lidarr/files/lidarr.in2
-rw-r--r--net-p2p/prowlarr/files/prowlarr.in1
-rw-r--r--net-p2p/radarr/Makefile1
-rw-r--r--net-p2p/radarr/files/radarr.in2
-rw-r--r--net-p2p/readarr/files/readarr.in1
11 files changed, 9 insertions, 9 deletions
diff --git a/multimedia/emby-server-devel/Makefile b/multimedia/emby-server-devel/Makefile
index fee7c865f589..5fb6f8f2d0b1 100644
--- a/multimedia/emby-server-devel/Makefile
+++ b/multimedia/emby-server-devel/Makefile
@@ -1,5 +1,5 @@
DISTVERSION= 4.8.0.47
-PORTREVISION= 0
+PORTREVISION= 1
PKGNAMESUFFIX= -devel
DIST_SUBDIR= ${PORTNAME}${PKGNAMESUFFIX}
diff --git a/multimedia/emby-server/Makefile b/multimedia/emby-server/Makefile
index f67d71697b19..af65e6559a27 100644
--- a/multimedia/emby-server/Makefile
+++ b/multimedia/emby-server/Makefile
@@ -1,6 +1,6 @@
PORTNAME= emby-server
DISTVERSION?= 4.7.14.0
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= multimedia
MASTER_SITES= https://github.com/MediaBrowser/Emby.Releases/releases/download/${DISTVERSION}/ \
https://mediabrowser.github.io/embytools/
diff --git a/multimedia/emby-server/files/emby-server.in b/multimedia/emby-server/files/emby-server.in
index d753175697b4..13bc85c4fed8 100644
--- a/multimedia/emby-server/files/emby-server.in
+++ b/multimedia/emby-server/files/emby-server.in
@@ -64,7 +64,7 @@ start_precmd=%%RC_NAME%%_start_precmd
# .NET 6+ use dual mode sockets to avoid the separate AF handling.
# disable .NET use of V6 if no ipv6 is configured.
# See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=259194#c17
- ifconfig | grep -q inet6
+ ifconfig -a -u -G lo | grep -q inet6
if [ $? == 1 ]; then
export DOTNET_SYSTEM_NET_DISABLEIPV6=1
fi
diff --git a/multimedia/jellyfin/Makefile b/multimedia/jellyfin/Makefile
index 4218a22cb614..c45b86232e3d 100644
--- a/multimedia/jellyfin/Makefile
+++ b/multimedia/jellyfin/Makefile
@@ -1,6 +1,6 @@
PORTNAME= jellyfin
DISTVERSION= 10.8.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia
MASTER_SITES= https://github.com/Thefrank/jellyfin-server-freebsd/releases/download/v${DISTVERSION}/
DISTFILES= jellyfin-combined_${DISTVERSION}_freebsd-${ARCH}.tar.gz \
diff --git a/multimedia/jellyfin/files/jellyfin.in b/multimedia/jellyfin/files/jellyfin.in
index 8cb52bc5cc60..1bc6b91cf0c7 100755
--- a/multimedia/jellyfin/files/jellyfin.in
+++ b/multimedia/jellyfin/files/jellyfin.in
@@ -60,7 +60,7 @@ jellyfin_precmd() {
# .NET 6+ use dual mode sockets to avoid the separate AF handling.
# disable .NET use of V6 if no ipv6 is configured.
# See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=259194#c17
- ifconfig | grep -q inet6
+ ifconfig -a -u -G lo | grep -q inet6
if [ $? == 1 ]; then
export DOTNET_SYSTEM_NET_DISABLEIPV6=1
fi
diff --git a/net-p2p/lidarr/Makefile b/net-p2p/lidarr/Makefile
index 567b970bc5a5..d11a95c98121 100644
--- a/net-p2p/lidarr/Makefile
+++ b/net-p2p/lidarr/Makefile
@@ -1,5 +1,6 @@
PORTNAME= lidarr
DISTVERSION= 1.3.5.3530
+PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= https://github.com/lidarr/Lidarr/releases/download/v${PORTVERSION}/
DISTNAME= Lidarr.master.${DISTVERSION}.freebsd-core-x64
diff --git a/net-p2p/lidarr/files/lidarr.in b/net-p2p/lidarr/files/lidarr.in
index db723160de4a..78f689ae38f4 100644
--- a/net-p2p/lidarr/files/lidarr.in
+++ b/net-p2p/lidarr/files/lidarr.in
@@ -43,7 +43,7 @@ start_precmd=${name}_precmd
# .NET 6+ use dual mode sockets to avoid the separate AF handling.
# disable .NET use of V6 if no ipv6 is configured.
# See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=259194#c17
- ifconfig | grep -q inet6
+ ifconfig -a -u -G lo | grep -q inet6
if [ $? == 1 ]; then
export DOTNET_SYSTEM_NET_DISABLEIPV6=1
fi
diff --git a/net-p2p/prowlarr/files/prowlarr.in b/net-p2p/prowlarr/files/prowlarr.in
index 67077c63802a..48d10a09c855 100644
--- a/net-p2p/prowlarr/files/prowlarr.in
+++ b/net-p2p/prowlarr/files/prowlarr.in
@@ -43,7 +43,6 @@ start_precmd=${name}_precmd
# .NET 6+ use dual mode sockets to avoid the separate AF handling.
# disable .NET use of V6 if no ipv6 is configured.
# See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=259194#c17
- # Later version by Keith Chiem through email
ifconfig -a -u -G lo | grep -q inet6
if [ $? == 1 ]; then
export DOTNET_SYSTEM_NET_DISABLEIPV6=1
diff --git a/net-p2p/radarr/Makefile b/net-p2p/radarr/Makefile
index 61e33777b354..4762766aeb6e 100644
--- a/net-p2p/radarr/Makefile
+++ b/net-p2p/radarr/Makefile
@@ -1,5 +1,6 @@
PORTNAME= radarr
DISTVERSION= 4.7.5.7809
+PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= https://github.com/Radarr/Radarr/releases/download/v${PORTVERSION}/
DISTNAME= Radarr.master.${DISTVERSION}.freebsd-core-x64
diff --git a/net-p2p/radarr/files/radarr.in b/net-p2p/radarr/files/radarr.in
index 90be8f5ce9b0..ebde62bb3eba 100644
--- a/net-p2p/radarr/files/radarr.in
+++ b/net-p2p/radarr/files/radarr.in
@@ -43,7 +43,7 @@ start_precmd=${name}_precmd
# .NET 6+ use dual mode sockets to avoid the separate AF handling.
# disable .NET use of V6 if no ipv6 is configured.
# See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=259194#c17
- ifconfig | grep -q inet6
+ ifconfig -a -u -G lo | grep -q inet6
if [ $? == 1 ]; then
export DOTNET_SYSTEM_NET_DISABLEIPV6=1
fi
diff --git a/net-p2p/readarr/files/readarr.in b/net-p2p/readarr/files/readarr.in
index 75ec18a1dd3b..9cd4c2f77458 100644
--- a/net-p2p/readarr/files/readarr.in
+++ b/net-p2p/readarr/files/readarr.in
@@ -43,7 +43,6 @@ start_precmd=${name}_precmd
# .NET 6+ use dual mode sockets to avoid the separate AF handling.
# disable .NET use of V6 if no ipv6 is configured.
# See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=259194#c17
- # Later version by Keith Chiem through email
ifconfig -a -u -G lo | grep -q inet6
if [ $? == 1 ]; then
export DOTNET_SYSTEM_NET_DISABLEIPV6=1