aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-08-05 12:48:12 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-08-06 12:42:48 +0000
commit5cf67bb382b03cb65dac3dd62854cb2f136e5233 (patch)
tree8282168af1c6f33087cf70aa54af9a4bc03d3148
parent18b138ae812cdfae0c4195c87554a984de288ae5 (diff)
downloadports-5cf67bb382b03cb65dac3dd62854cb2f136e5233.tar.gz
ports-5cf67bb382b03cb65dac3dd62854cb2f136e5233.zip
emulators/tic-80: fix build on amd64 CURRENT
Import an upstream patch to fix an incorrect alignment specifier. Obtained from: https://github.com/wasm3/wasm3/commit/d3a763c84ce6b78b730332900036b2be0e0e0794 Reported by: fallout MFH: 2023Q3
-rw-r--r--emulators/tic-80/Makefile2
-rw-r--r--emulators/tic-80/files/patch-vendor_wasm3_source_m3__config__platforms.h14
2 files changed, 15 insertions, 1 deletions
diff --git a/emulators/tic-80/Makefile b/emulators/tic-80/Makefile
index 1aa5ccf5583c..b84bd35e3c34 100644
--- a/emulators/tic-80/Makefile
+++ b/emulators/tic-80/Makefile
@@ -1,7 +1,7 @@
PORTNAME= TIC-80
DISTVERSIONPREFIX= v
DISTVERSION= 1.0.2164
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators games
MAINTAINER= fuz@FreeBSD.org
diff --git a/emulators/tic-80/files/patch-vendor_wasm3_source_m3__config__platforms.h b/emulators/tic-80/files/patch-vendor_wasm3_source_m3__config__platforms.h
new file mode 100644
index 000000000000..7d289b088865
--- /dev/null
+++ b/emulators/tic-80/files/patch-vendor_wasm3_source_m3__config__platforms.h
@@ -0,0 +1,14 @@
+--- vendor/wasm3/source/m3_config_platforms.h.orig 2023-08-05 12:47:20 UTC
++++ vendor/wasm3/source/m3_config_platforms.h
+@@ -121,9 +121,9 @@ typedef int8_t i8;
+ # if defined (M3_COMPILER_MSVC)
+ # define vectorcall // For MSVC, better not to specify any call convention
+ # elif defined(__x86_64__)
+-# define vectorcall __attribute__((aligned(32)))
++# define vectorcall
+ //# elif defined(__riscv) && (__riscv_xlen == 64)
+-//# define vectorcall __attribute__((aligned(16)))
++//# define vectorcall
+ # elif defined(__MINGW32__)
+ # define vectorcall
+ # elif defined(WIN32)