aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-10-25 14:43:06 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-10-25 15:57:05 +0000
commit5d011fa62bce9c8d95233dacbe03755a37d6b2f7 (patch)
tree9039cd2fdd6a81de6dbfbb05490a96bfe1e27b95
parent70b81836d936aa2ade6db83a23f5500b339a4da2 (diff)
downloadports-5d011fa62bce9c8d95233dacbe03755a37d6b2f7.tar.gz
ports-5d011fa62bce9c8d95233dacbe03755a37d6b2f7.zip
devel/py-ipykernel: Add py-ipykernel 6.4.2
The IPython kernel is the Python execution backend for Jupyter. WWW: https://ipython.org/ WWW: https://github.com/ipython/ipykernel
-rw-r--r--MOVED1
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-ipykernel/Makefile35
-rw-r--r--devel/py-ipykernel/distinfo3
-rw-r--r--devel/py-ipykernel/pkg-descr4
5 files changed, 43 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index bb0c2e989b55..82febe766929 100644
--- a/MOVED
+++ b/MOVED
@@ -14909,7 +14909,6 @@ sysutils/livecd||2020-05-05|Has expired: Broken for more than 6 months
deskutils/osynctool||2020-05-06|Abandonware, website disappeared
devel/libopensync||2020-05-06|Abandonware, website disappeared
deskutils/libopensync-plugin-vformat-devel||2020-05-06|Abandonware, website disappeared
-devel/py-ipykernel|devel/py-ipykernel5|2020-05-07|Has expired: Old version, use devel/py-ipykernel5 instead
sysutils/rundeck|sysutils/rundeck2|2020-05-07|Rename to avoid confusion with sysutils/rundeck3
math/darknet|misc/darknet|2020-05-07|DarkNet is a machine learning project, not a math project
www/rubygem-activeresource5|www/rubygem-activeresource|2020-05-08|Remove PKGNAMESUFFIX 3 years and 4 months after rubygem-activeresource removal
diff --git a/devel/Makefile b/devel/Makefile
index 500c19f93abf..4b583b9de3aa 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4610,6 +4610,7 @@
SUBDIR += py-iopath
SUBDIR += py-ipaddr
SUBDIR += py-ipdb
+ SUBDIR += py-ipykernel
SUBDIR += py-ipykernel5
SUBDIR += py-ipympl
SUBDIR += py-ipyparallel
diff --git a/devel/py-ipykernel/Makefile b/devel/py-ipykernel/Makefile
new file mode 100644
index 000000000000..042aa0939718
--- /dev/null
+++ b/devel/py-ipykernel/Makefile
@@ -0,0 +1,35 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= ipykernel
+PORTVERSION= 6.4.2
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= IPython Kernel for Jupyter
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING.md
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}debugpy>=1.0.0<2.0:devel/py-debugpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ipython>=7.23.1<8.0:devel/ipython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ipython_genutils>=0:devel/py-ipython_genutils@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jupyter-client>=0<8.0:devel/py-jupyter-client@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib-inline>=0.1.0<0.2.0:math/py-matplotlib-inline@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tornado>=4.2<7.0:www/py-tornado@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}traitlets>=4.1.0<6.0:devel/py-traitlets@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 30800
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}argcomplete>=0<1.12.4:devel/py-argcomplete@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=0<5:devel/py-importlib-metadata@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-ipykernel/distinfo b/devel/py-ipykernel/distinfo
new file mode 100644
index 000000000000..a409085c1f77
--- /dev/null
+++ b/devel/py-ipykernel/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1634391080
+SHA256 (ipykernel-6.4.2.tar.gz) = 0140f78bfd60e47e387b6433b4bed0f228986420dc4d5fac0e251c9711e23e29
+SIZE (ipykernel-6.4.2.tar.gz) = 121253
diff --git a/devel/py-ipykernel/pkg-descr b/devel/py-ipykernel/pkg-descr
new file mode 100644
index 000000000000..78650243d528
--- /dev/null
+++ b/devel/py-ipykernel/pkg-descr
@@ -0,0 +1,4 @@
+The IPython kernel is the Python execution backend for Jupyter.
+
+WWW: https://ipython.org/
+WWW: https://github.com/ipython/ipykernel