aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2024-05-05 14:44:55 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2024-05-05 14:47:05 +0000
commit5d736fc85e42aac2649de640037dc54382176691 (patch)
tree5f97cfd92b10654c0900969f30fe19eae0899371
parent17043121295573db9777f6dd31364ee356e3154c (diff)
downloadports-5d736fc85e42aac2649de640037dc54382176691.tar.gz
ports-5d736fc85e42aac2649de640037dc54382176691.zip
biology/kallisto: Use EXTRACT_AFTER_ARGS to omit unused htslib dir
Reduces I/O during builds PR: 278739 Reported by: diizzy
-rw-r--r--biology/kallisto/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/biology/kallisto/Makefile b/biology/kallisto/Makefile
index 8774208d9097..158ff03a9137 100644
--- a/biology/kallisto/Makefile
+++ b/biology/kallisto/Makefile
@@ -1,6 +1,7 @@
PORTNAME= kallisto
DISTVERSIONPREFIX= v
DISTVERSION= 0.50.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= biology
@@ -22,6 +23,8 @@ USES= cmake:noninja compiler:c++11-lang gmake localbase:ldflags
USE_GITHUB= yes
GH_ACCOUNT= pachterlab
+EXTRACT_AFTER_ARGS= --exclude ${GH_PROJECT_DEFAULT}-${GH_TAGNAME_EXTRACT}/ext/htslib --no-same-owner --no-same-permissions
+
SUB_FILES= kallisto-test
PORTEXAMPLES= *
@@ -39,9 +42,6 @@ LDFLAGS+= -lhts -lz
OPTIONS_DEFINE= EXAMPLES
-post-extract:
- ${RM} -rf ${WRKSRC}/ext/htslib
-
post-install-EXAMPLES-on:
${INSTALL_SCRIPT} ${WRKDIR}/kallisto-test ${STAGEDIR}${PREFIX}/bin
cd ${WRKSRC}/test && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}