aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-03-21 14:50:03 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-03-21 14:52:55 +0000
commit5dc1c7edbe955020808f3eca113d1a5f053b67f7 (patch)
treec057f5d50d96219434ca81211229e3294016a4d6
parentb3463e73484336da10d1411f8857da9bb2ec5489 (diff)
downloadports-5dc1c7edbe955020808f3eca113d1a5f053b67f7.tar.gz
ports-5dc1c7edbe955020808f3eca113d1a5f053b67f7.zip
devel/libdatrie: Fix BUILD
While converters/libiconv is installed libdatrie fails to build as it tries to use the iconv library from libc which do not contain all the funcntionalities of libiconv. So rather than depending on the base of iconv switch to the port version entirely. PR: 266241 Reported by: se
-rw-r--r--devel/libdatrie/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/devel/libdatrie/Makefile b/devel/libdatrie/Makefile
index 86ea9a5d8b12..95dad1c01253 100644
--- a/devel/libdatrie/Makefile
+++ b/devel/libdatrie/Makefile
@@ -1,5 +1,6 @@
PORTNAME= libdatrie
PORTVERSION= 0.2.13
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://linux.thai.net/pub/thailinux/software/libthai/
@@ -10,12 +11,13 @@ WWW= https://linux.thai.net/projects/datrie/
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= iconv libtool localbase:ldflags pathfix tar:xz
-GNU_CONFIGURE= yes
+USES= iconv:wchar_t libtool localbase:ldflags pathfix tar:xz
USE_LDCONFIG= yes
-LDFLAGS+= ${ICONV_LIB}
+GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
+LDFLAGS+= ${ICONV_LIB}
+
.include <bsd.port.mk>