aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-09 13:53:41 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-09 14:06:51 +0000
commit5de4d54c6dee424d5a210c36402dc5665dceaf9f (patch)
tree13a709c68625240f50cd6115329d02ddd114b0fa
parentd7961740ab94fbfe1b4aacf14270647eca7cacb1 (diff)
downloadports-5de4d54c6dee424d5a210c36402dc5665dceaf9f.tar.gz
ports-5de4d54c6dee424d5a210c36402dc5665dceaf9f.zip
net/rubygem-grpc: Update to 1.62.0
-rw-r--r--net/rubygem-grpc/Makefile2
-rw-r--r--net/rubygem-grpc/distinfo6
-rw-r--r--net/rubygem-grpc/files/patch-clang1622
3 files changed, 4 insertions, 26 deletions
diff --git a/net/rubygem-grpc/Makefile b/net/rubygem-grpc/Makefile
index f07844b45a69..d11b2a391ecf 100644
--- a/net/rubygem-grpc/Makefile
+++ b/net/rubygem-grpc/Makefile
@@ -1,5 +1,5 @@
PORTNAME= grpc
-PORTVERSION= 1.61.0
+PORTVERSION= 1.62.0
CATEGORIES= net rubygems
MASTER_SITES= RG
diff --git a/net/rubygem-grpc/distinfo b/net/rubygem-grpc/distinfo
index 2f806c7ec5ed..fe7e94bee447 100644
--- a/net/rubygem-grpc/distinfo
+++ b/net/rubygem-grpc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1708450548
-SHA256 (rubygem/grpc-1.61.0.gem) = 6c0e2466520fb51ade06e7ae53e88202caf8e659c9676e613e758de181c52e26
-SIZE (rubygem/grpc-1.61.0.gem) = 6508544
+TIMESTAMP = 1709390974
+SHA256 (rubygem/grpc-1.62.0.gem) = f624d44ce89764ed61bd0d8c585bd6d7ec4b75ad421bdc7b370f09f101f6e80f
+SIZE (rubygem/grpc-1.62.0.gem) = 6573056
diff --git a/net/rubygem-grpc/files/patch-clang16 b/net/rubygem-grpc/files/patch-clang16
deleted file mode 100644
index 2e466f457ec7..000000000000
--- a/net/rubygem-grpc/files/patch-clang16
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/ruby/ext/grpc/rb_channel.c.orig 2023-12-08 17:22:30 UTC
-+++ src/ruby/ext/grpc/rb_channel.c
-@@ -726,7 +726,7 @@ static void run_poll_channels_loop_unblocking_func(voi
- }
-
- // Poll channel connectivity states in background thread without the GIL.
--static VALUE run_poll_channels_loop(VALUE arg) {
-+static VALUE run_poll_channels_loop(void *arg) {
- (void)arg;
- gpr_log(
- GPR_DEBUG,
---- src/ruby/ext/grpc/rb_event_thread.c.orig 2023-12-08 17:22:30 UTC
-+++ src/ruby/ext/grpc/rb_event_thread.c
-@@ -116,7 +116,7 @@ static void grpc_rb_event_unblocking_func(void* arg) {
-
- /* This is the implementation of the thread that handles auth metadata plugin
- * events */
--static VALUE grpc_rb_event_thread(VALUE arg) {
-+static VALUE grpc_rb_event_thread(void *arg) {
- grpc_rb_event* event;
- (void)arg;
- while (true) {