aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-18 17:51:42 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-18 18:00:42 +0000
commit5e663a4f8f3ca208b1757feea4635be259e27092 (patch)
tree3cb249d8e4484ccd526e9df35b004f4a15616bef
parent9316129e30438c26c0f6096352c6c4844ccf64ff (diff)
downloadports-5e663a4f8f3ca208b1757feea4635be259e27092.tar.gz
ports-5e663a4f8f3ca208b1757feea4635be259e27092.zip
security/py-pyhanko: Add py-pyhanko 0.17.2
The lack of open-source CLI tooling to handle digitally signing and stamping PDF files was bothering me, so I went ahead and rolled my own. Note: The working title of this project (and former name of the repository on GitHub) was pdf-stamp, which might still linger in some references.
-rw-r--r--security/Makefile1
-rw-r--r--security/py-pyhanko/Makefile30
-rw-r--r--security/py-pyhanko/distinfo3
-rw-r--r--security/py-pyhanko/files/patch-setup.py10
-rw-r--r--security/py-pyhanko/pkg-descr5
5 files changed, 49 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index efe5824eb34c..56c0cb233f06 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -958,6 +958,7 @@
SUBDIR += py-pycryptodome-test-vectors
SUBDIR += py-pycryptodomex
SUBDIR += py-pyelliptic
+ SUBDIR += py-pyhanko
SUBDIR += py-pyhanko-certvalidator
SUBDIR += py-pylibacl
SUBDIR += py-pymacaroons
diff --git a/security/py-pyhanko/Makefile b/security/py-pyhanko/Makefile
new file mode 100644
index 000000000000..beb8a6b99f39
--- /dev/null
+++ b/security/py-pyhanko/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= pyhanko
+PORTVERSION= 0.17.2
+CATEGORIES= security python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyHanko-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Tools for stamping and signing PDF files
+WWW= https://github.com/MatthiasValvekens/pyHanko
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1crypto>=1.5.1:devel/py-asn1crypto@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>=7.1.2:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cryptography>=3.3.1:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyhanko-certvalidator>=0.20<0.21:security/py-pyhanko-certvalidator@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=2020.1,1:devel/py-pytz@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=5.3.1:devel/py-yaml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}qrcode>=6.1:textproc/py-qrcode@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.24.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tzlocal>=2.1:devel/py-tzlocal@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-pyhanko/distinfo b/security/py-pyhanko/distinfo
new file mode 100644
index 000000000000..3f23f90dd60d
--- /dev/null
+++ b/security/py-pyhanko/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1681052896
+SHA256 (pyHanko-0.17.2.tar.gz) = b1f027f0f63a0c9f6c457652c8d1f5c959e6569ec79cdcdbee19cf8f9f2ad423
+SIZE (pyHanko-0.17.2.tar.gz) = 334201
diff --git a/security/py-pyhanko/files/patch-setup.py b/security/py-pyhanko/files/patch-setup.py
new file mode 100644
index 000000000000..078e8d6520af
--- /dev/null
+++ b/security/py-pyhanko/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2023-03-09 22:50:58 UTC
++++ setup.py
+@@ -70,7 +70,6 @@ setup(
+ 'cryptography>=3.3.1'
+ ],
+ setup_requires=[
+- 'wheel', 'pytest-runner'
+ ],
+ extras_require={
+ 'extra_pubkey_algs': ['oscrypto>=1.2.1'],
diff --git a/security/py-pyhanko/pkg-descr b/security/py-pyhanko/pkg-descr
new file mode 100644
index 000000000000..2409be54cf91
--- /dev/null
+++ b/security/py-pyhanko/pkg-descr
@@ -0,0 +1,5 @@
+The lack of open-source CLI tooling to handle digitally signing and stamping PDF
+files was bothering me, so I went ahead and rolled my own.
+
+Note: The working title of this project (and former name of the repository on
+GitHub) was pdf-stamp, which might still linger in some references.