aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2023-07-02 21:47:18 +0000
committerMatthias Andree <mandree@FreeBSD.org>2023-07-09 22:08:11 +0000
commit5e7242d99af0988c1a6d12cac50f75e0ba9d63dc (patch)
treed3cdb107b5a1c414a81fe420fc9ede9882e95a68
parent164a774986db9c3161e903ddd059f6e54c7b5981 (diff)
downloadports-5e7242d99af0988c1a6d12cac50f75e0ba9d63dc.tar.gz
ports-5e7242d99af0988c1a6d12cac50f75e0ba9d63dc.zip
deskutils/pinot: make compatible with exiv2 0.28
PR: 272311
-rw-r--r--deskutils/pinot/Makefile2
-rw-r--r--deskutils/pinot/files/patch-Tokenize_filters_Exiv2ImageFilter.cc20
2 files changed, 21 insertions, 1 deletions
diff --git a/deskutils/pinot/Makefile b/deskutils/pinot/Makefile
index 43e07259ea10..1a67b04c177f 100644
--- a/deskutils/pinot/Makefile
+++ b/deskutils/pinot/Makefile
@@ -1,6 +1,6 @@
PORTNAME= pinot
PORTVERSION= 1.21
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= deskutils
MAINTAINER= thierry@FreeBSD.org
diff --git a/deskutils/pinot/files/patch-Tokenize_filters_Exiv2ImageFilter.cc b/deskutils/pinot/files/patch-Tokenize_filters_Exiv2ImageFilter.cc
new file mode 100644
index 000000000000..6feb36bc6a12
--- /dev/null
+++ b/deskutils/pinot/files/patch-Tokenize_filters_Exiv2ImageFilter.cc
@@ -0,0 +1,20 @@
+--- Tokenize/filters/Exiv2ImageFilter.cc.orig 2022-02-22 20:31:11 UTC
++++ Tokenize/filters/Exiv2ImageFilter.cc
+@@ -236,7 +236,7 @@ bool Exiv2ImageFilter::next_document(void)
+
+ try
+ {
+- Exiv2::Image::AutoPtr image = Exiv2::ImageFactory::open(m_filePath);
++ Exiv2::Image::UniquePtr image { Exiv2::ImageFactory::open(m_filePath) };
+ if (image.get() == NULL)
+ {
+ clog << m_filePath.c_str() << " is not an image" << endl;
+@@ -388,7 +388,7 @@ bool Exiv2ImageFilter::next_document(void)
+ }
+ }
+ }
+- catch (Exiv2::AnyError &e)
++ catch (Exiv2::Error &e)
+ {
+ clog << "Caught exiv2 exception: " << e << endl;
+ foundData = false;