aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2024-01-01 15:27:58 +0000
committerMikael Urankar <mikael@FreeBSD.org>2024-01-01 18:08:35 +0000
commit5ed4c6d33aef515c44eb35a27f2cc89ade1d3ec0 (patch)
treead2120b493f44eaf2fd676aa1a8c012e01f5f39d
parent2682b5b69c38be89bd5313865b4c980fe6d16b2c (diff)
downloadports-5ed4c6d33aef515c44eb35a27f2cc89ade1d3ec0.tar.gz
ports-5ed4c6d33aef515c44eb35a27f2cc89ade1d3ec0.zip
x11/sirula: Unbreak build
Fix typo: error: expected one of `(`, `.`, `::`, `;`, `?`, `}`, or an operator, found `:` --> /build/cargo-vendor-dir/osstrtools-0.2.2/src/lib.rs:754:42 | 754 | unsafe { (bytes as *const _).cast:() } | ^ expected one of 7 possible tokens error: could not compile `osstrtools` (lib) due to previous error Typo was added in https://github.com/rabite0/osstrtools/commit/1179a979dbf22209547a74ce98d84745d1e54ef4 Approved by: portmgr (build fix blanket)
-rw-r--r--x11/sirula/Makefile2
-rw-r--r--x11/sirula/files/patch-osstrtools11
2 files changed, 11 insertions, 2 deletions
diff --git a/x11/sirula/Makefile b/x11/sirula/Makefile
index 6760dbe031c0..405833ecafc0 100644
--- a/x11/sirula/Makefile
+++ b/x11/sirula/Makefile
@@ -11,8 +11,6 @@ WWW= https://github.com/DorianRudolph/sirula
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= could not compile osstrtools
-
LIB_DEPENDS= libgtk-layer-shell.so:x11-toolkits/gtk-layer-shell
USES= cargo gnome
diff --git a/x11/sirula/files/patch-osstrtools b/x11/sirula/files/patch-osstrtools
new file mode 100644
index 000000000000..3b367d97416b
--- /dev/null
+++ b/x11/sirula/files/patch-osstrtools
@@ -0,0 +1,11 @@
+--- cargo-crates/osstrtools-0.2.2/src/lib.rs.orig 2024-01-01 16:19:06 UTC
++++ cargo-crates/osstrtools-0.2.2/src/lib.rs
+@@ -751,7 +751,7 @@ impl WinOsStr for OsStr {
+
+ fn as_bytes<'s>(&'s self) -> &'s [u8] {
+ // This should be fine in any case, as OsStr is just a &[u8]
+- unsafe { (bytes as *const _).cast:() }
++ unsafe { (bytes as *const _).cast() }
+ }
+ }
+