aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-12-27 21:32:41 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-12-27 21:32:41 +0000
commit5f03f3518e0a9655c57c73d4e42903cc25f18714 (patch)
tree89a218718dba4af51e8be4822b1ec018efef20a3
parent11cd9ddf548e34d21ee6bb02b33d5193eefa7c21 (diff)
downloadports-5f03f3518e0a9655c57c73d4e42903cc25f18714.tar.gz
ports-5f03f3518e0a9655c57c73d4e42903cc25f18714.zip
arabic/py-hijri-converter: New port: Hijri-Gregorian dates converter based on the Umm al-Qura calendar
-rw-r--r--arabic/Makefile1
-rw-r--r--arabic/py-hijri-converter/Makefile21
-rw-r--r--arabic/py-hijri-converter/distinfo3
-rw-r--r--arabic/py-hijri-converter/pkg-descr15
4 files changed, 40 insertions, 0 deletions
diff --git a/arabic/Makefile b/arabic/Makefile
index d7d8182dabf0..139386b22eb6 100644
--- a/arabic/Makefile
+++ b/arabic/Makefile
@@ -8,5 +8,6 @@
SUBDIR += khotot
SUBDIR += libitl
SUBDIR += libreoffice
+ SUBDIR += py-hijri-converter
.include <bsd.port.subdir.mk>
diff --git a/arabic/py-hijri-converter/Makefile b/arabic/py-hijri-converter/Makefile
new file mode 100644
index 000000000000..f22d420745e7
--- /dev/null
+++ b/arabic/py-hijri-converter/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= hijri-converter
+DISTVERSION= 2.2.4
+CATEGORIES= arabic python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Hijri-Gregorian dates converter based on the Umm al-Qura calendar
+WWW= https://hijri-converter.readthedocs.io/en/stable/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist pytest
+
+NO_ARCH= yes
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/arabic/py-hijri-converter/distinfo b/arabic/py-hijri-converter/distinfo
new file mode 100644
index 000000000000..6db01253ce6d
--- /dev/null
+++ b/arabic/py-hijri-converter/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1672176341
+SHA256 (hijri-converter-2.2.4.tar.gz) = 9e1d9fa4c220f6867da2abb1a96240675ae974abba951c686a781f4ef6ac218f
+SIZE (hijri-converter-2.2.4.tar.gz) = 34899
diff --git a/arabic/py-hijri-converter/pkg-descr b/arabic/py-hijri-converter/pkg-descr
new file mode 100644
index 000000000000..a1306bd6d47d
--- /dev/null
+++ b/arabic/py-hijri-converter/pkg-descr
@@ -0,0 +1,15 @@
+hijri-converter is a Python package to convert accurately between Hijri and
+Gregorian dates using the Umm al-Qura calendar.
+
+Features:
+* Accurate and verified date conversion.
+* Optimized code performance compared to similar packages.
+* Intuitive, clean, and easy-to-use interface.
+* Most of the methods and formats are similar to those of standard library.
+* Multilingual representation of weekday names, months, and calendar era
+ notations.
+* Easily extendable to support other natural languages.
+* Rich comparison between dates.
+* Validation of input dates.
+* Works on Python 3.6+ with zero dependencies.
+* Thoroughly tested with 100% test coverage.