aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-04-09 13:28:59 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-05-25 13:55:44 +0000
commit5f69415313f894338dca54e21b5c3981e5e5f58f (patch)
tree936ed6c9018556107a7d166f0862aae19bf6c652
parent40d7b487381cc91eb3156103e6ffe8c02d5e8a70 (diff)
downloadports-5f69415313f894338dca54e21b5c3981e5e5f58f.tar.gz
ports-5f69415313f894338dca54e21b5c3981e5e5f58f.zip
Mk: switch from PYTHON_PORTVERSION to PYTHON_DISTVERSION
This brings python framework in consistense with handbook recommendations to prefer DISTVERSION and simplifies adding prerelease versions of python PR: 255013 Differential Revision: https://reviews.freebsd.org/D29418 Exp-run by: antoine Approved by: wen@, no objection from python@ or portmgr@
-rw-r--r--Mk/Uses/python.mk6
-rw-r--r--databases/py-gdbm/Makefile8
-rw-r--r--databases/py-sqlite3/Makefile10
-rw-r--r--lang/pypy/bsd.pypy.cffi.mk2
-rw-r--r--lang/python-doc-html/Makefile9
-rw-r--r--lang/python-tools/Makefile6
-rw-r--r--lang/python27/Makefile10
-rw-r--r--lang/python27/Makefile.version2
-rw-r--r--lang/python27/pkg-plist6
-rw-r--r--lang/python36/Makefile12
-rw-r--r--lang/python36/Makefile.version2
-rw-r--r--lang/python37/Makefile12
-rw-r--r--lang/python37/Makefile.version2
-rw-r--r--lang/python38/Makefile12
-rw-r--r--lang/python38/Makefile.version2
-rw-r--r--lang/python39/Makefile12
-rw-r--r--lang/python39/Makefile.version2
-rw-r--r--lang/tauthon/Makefile2
-rw-r--r--x11-toolkits/py-tkinter/Makefile8
19 files changed, 62 insertions, 63 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index aaece9e92c2e..fcaf479d8076 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -168,8 +168,8 @@
# PYTHONBASE - The installation prefix of the chosen Python
# interpreter, e.g. /usr/local
#
-# PYTHON_PORTVERSION
-# - Version number suitable for ${PORTVERSION}.
+# PYTHON_DISTVERSION
+# - Version number suitable for ${DISTVERSION}.
#
# PYTHON_PORTSDIR - The port directory of the chosen Python interpreter
#
@@ -458,7 +458,7 @@ PYTHON_PORTSDIR= ${_PYTHON_RELPORTDIR}${PYTHON_SUFFIX}
# tokens if it's a single character. Only use the the first 3 tokens of
# PORTVERSION to support pre-release versions (rc3, alpha4, etc) of
# any Python port (lang/pythonXY)
-PYTHON_REL= ${PYTHON_PORTVERSION:C/^([0-9]+\.[0-9]+\.[0-9]+).*/\1/:C/\.([0-9])$/.0\1/:C/\.([0-9]\.[0-9]+)/.0\1/:S/.//g}
+PYTHON_REL= ${PYTHON_DISTVERSION:C/^([0-9]+\.[0-9]+\.[0-9]+).*/\1/:C/\.([0-9])$/.0\1/:C/\.([0-9]\.[0-9]+)/.0\1/:S/.//g}
# Might be overridden by calling ports
PYTHON_CMD?= ${_PYTHON_BASECMD}${_PYTHON_VERSION}
diff --git a/databases/py-gdbm/Makefile b/databases/py-gdbm/Makefile
index 5d53725c9a1e..bd024726a8ff 100644
--- a/databases/py-gdbm/Makefile
+++ b/databases/py-gdbm/Makefile
@@ -1,12 +1,12 @@
# Created by: Thomas Gellekum <tg@FreeBSD.org>
PORTNAME= gdbm
-PORTVERSION= ${PYTHON_PORTVERSION}
+DISTVERSION= ${PYTHON_DISTVERSION}
PORTREVISION= 6
CATEGORIES= databases python
-MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
+MASTER_SITES= PYTHON/ftp/python/${DISTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= Python-${PORTVERSION}
+DISTNAME= Python-${DISTVERSION}
MAINTAINER= python@FreeBSD.org
COMMENT= Python bindings to the GNU dbm library (Python ${PYTHON_VER})
@@ -24,7 +24,7 @@ PYDISTUTILS_INSTALLARGS+= --install-lib ${PYTHONPREFIX_LIBDIR}/lib-dynload
DIST_SUBDIR= python
DISTINFO_FILE= ${PORTSDIR}/lang/python${PYTHON_SUFFIX}/distinfo
-WRKSRC= ${WRKDIR}/Python-${PORTVERSION}/Modules
+WRKSRC= ${WRKDIR}/Python-${DISTVERSION}/Modules
post-extract:
@${CP} ${FILESDIR}/setup3.py ${WRKSRC}/setup.py
diff --git a/databases/py-sqlite3/Makefile b/databases/py-sqlite3/Makefile
index 1941d0609ef4..1f6125d10b0b 100644
--- a/databases/py-sqlite3/Makefile
+++ b/databases/py-sqlite3/Makefile
@@ -1,19 +1,19 @@
# Created by: Hye-Shik Chang
PORTNAME= sqlite3
-PORTVERSION= ${PYTHON_PORTVERSION}
+DISTVERSION= ${PYTHON_DISTVERSION}
PORTREVISION= 7
CATEGORIES= databases python
-MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
+MASTER_SITES= PYTHON/ftp/python/${DISTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= Python-${PORTVERSION}
+DISTNAME= Python-${DISTVERSION}
DIST_SUBDIR= python
MAINTAINER= python@FreeBSD.org
COMMENT= Standard Python binding to the SQLite3 library (Python ${PYTHON_VER})
LICENSE= PSFL
-LICENSE_FILE= ${WRKDIR}/Python-${PORTVERSION}/LICENSE
+LICENSE_FILE= ${WRKDIR}/Python-${DISTVERSION}/LICENSE
LIB_DEPENDS= libsqlite3.so:databases/sqlite3
@@ -23,7 +23,7 @@ USES= compiler:c11 python:2.7+ tar:xz
USE_PYTHON= autoplist distutils allflavors
DISTINFO_FILE= ${PORTSDIR}/lang/python${PYTHON_SUFFIX}/distinfo
-WRKSRC= ${WRKDIR}/Python-${PORTVERSION}/Modules
+WRKSRC= ${WRKDIR}/Python-${DISTVERSION}/Modules
PYDISTUTILS_INSTALLARGS+= --install-lib ${PYTHON_LIBDIR}/lib-dynload
diff --git a/lang/pypy/bsd.pypy.cffi.mk b/lang/pypy/bsd.pypy.cffi.mk
index 1243f8fbd972..ee0b50f74355 100644
--- a/lang/pypy/bsd.pypy.cffi.mk
+++ b/lang/pypy/bsd.pypy.cffi.mk
@@ -12,7 +12,7 @@ FLAVORS= pypy pypy3
FLAVOR?= ${FLAVORS:[1]}
PYTHON_IMPL= ${FLAVOR}
-PYTHON_PORTVERSION= ${DISTVERSION}
+PYTHON_DISTVERSION= ${DISTVERSION}
PYTHON_PKGNAMEPREFIX= ${PYTHON_IMPL}-
PYTHON_CMD= ${LOCALBASE}/bin/${PYTHON_IMPL}
diff --git a/lang/python-doc-html/Makefile b/lang/python-doc-html/Makefile
index 6b0e9d5fadc5..e41861989edf 100644
--- a/lang/python-doc-html/Makefile
+++ b/lang/python-doc-html/Makefile
@@ -1,11 +1,11 @@
# Created by: Thomas Gellekum <tg@FreeBSD.org>
PORTNAME= python-doc-${DOCFORMAT}
-PORTVERSION= ${PYTHON_PORTVERSION}
+DISTVERSION= ${PYTHON_DISTVERSION}
CATEGORIES= lang python
-MASTER_SITES?= PYTHON/ftp/python/doc/${PORTVERSION} \
+MASTER_SITES= PYTHON/ftp/python/doc/${DISTVERSION} \
PYTHON/ftp/python/doc/current
-DISTNAME= python-${PORTVERSION}-docs-${DOCFORMAT}
+DISTNAME= python-${DISTVERSION}-docs-${DOCFORMAT}
DIST_SUBDIR= python
MAINTAINER= python@FreeBSD.org
@@ -37,8 +37,7 @@ _VERS!= ${MAKE} -V _PYTHON_VERSIONS:O
.endif
all_python_versions:
-.for v in ${_VERS}
- @${MAKE} -C ${PORTSDIR}/lang/python${v:S/.//} -V PYTHON_PORTVERSION
+ @${MAKE} -C ${PORTSDIR}/lang/python${v:S/.//} -V PYTHON_DISTVERSION
.endfor
.if make(makesum)
diff --git a/lang/python-tools/Makefile b/lang/python-tools/Makefile
index 4215cf5411bc..6670a6dc75e8 100644
--- a/lang/python-tools/Makefile
+++ b/lang/python-tools/Makefile
@@ -1,10 +1,10 @@
PORTNAME= python-tools
-PORTVERSION= ${PYTHON_PORTVERSION}
+DISTVERSION= ${PYTHON_DISTVERSION}
PORTREVISION= 1
CATEGORIES= lang python devel
-MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
+MASTER_SITES= PYTHON/ftp/python/${DISTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= Python-${PORTVERSION}
+DISTNAME= Python-${DISTVERSION}
MAINTAINER= python@FreeBSD.org
COMMENT= Supplementary tools for the Python language
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 26465776d71c..5660be5a3a6f 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -1,10 +1,10 @@
PORTNAME= python
-PORTVERSION= ${PYTHON_PORTVERSION}
+DISTVERSION= ${PYTHON_DISTVERSION}
PORTREVISION= 1
CATEGORIES= lang python
-MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
+MASTER_SITES= PYTHON/ftp/python/${DISTVERSION}
PKGNAMESUFFIX= 27
-DISTNAME= Python-${PORTVERSION}
+DISTNAME= Python-${DISTVERSION}
DIST_SUBDIR= python
MAINTAINER= python@FreeBSD.org
@@ -19,7 +19,7 @@ USES= cpe ncurses pathfix pkgconfig readline shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-python_CMD= ${PREFIX}/bin/python${PYTHON_PORTVERSION:R}
+python_CMD= ${PREFIX}/bin/python${PYTHON_DISTVERSION:R}
SHEBANG_FILES= Lib/lib2to3/pgen2/*.py Lib/lib2to3/tests/*.py Lib/lib2to3/tests/data/*.py \
Lib/idlelib/*.py Lib/encodings/*.py Lib/test/*.py Lib/UserString.py \
Lib/base64.py Lib/cProfile.py Lib/keyword.py Lib/mimify.py Lib/pdb.py \
@@ -38,7 +38,7 @@ TEST_ARGS= TESTOPTS=-j${MAKE_JOBS_NUMBER}
MAKE_ARGS+= INSTALL_SHARED="${INSTALL_LIB}" # Strip shared library
PLIST_SUB= ABI=${ABIFLAGS} \
- PORTVERSION=${PORTVERSION} \
+ DISTVERSION=${DISTVERSION} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. https://bugs.python.org/issue19554
OPTIONS_DEFINE= DEBUG IPV6 LIBFFI NLS PYMALLOC THREADS
diff --git a/lang/python27/Makefile.version b/lang/python27/Makefile.version
index 60f9e65f900e..0a0288063c49 100644
--- a/lang/python27/Makefile.version
+++ b/lang/python27/Makefile.version
@@ -2,4 +2,4 @@
# Do not forget to update python documentation (lang/python-doc-*)
# Run "make -C lang/python-doc-html makesum"
-PYTHON_PORTVERSION= 2.7.18
+PYTHON_DISTVERSION= 2.7.18
diff --git a/lang/python27/pkg-plist b/lang/python27/pkg-plist
index 550a0e13a43c..10392a5be988 100644
--- a/lang/python27/pkg-plist
+++ b/lang/python27/pkg-plist
@@ -1892,7 +1892,7 @@ lib/python2.7/json/tool.pyo
lib/python2.7/keyword.py
lib/python2.7/keyword.pyc
lib/python2.7/keyword.pyo
-lib/python2.7/lib-dynload/Python-%%PORTVERSION%%-py2.7.egg-info
+lib/python2.7/lib-dynload/Python-%%DISTVERSION%%-py2.7.egg-info
lib/python2.7/lib-dynload/_bisect.so
lib/python2.7/lib-dynload/_codecs_cn.so
lib/python2.7/lib-dynload/_codecs_hk.so
@@ -2065,9 +2065,9 @@ lib/python2.7/lib-tk/ttk.pyo
lib/python2.7/lib-tk/turtle.py
lib/python2.7/lib-tk/turtle.pyc
lib/python2.7/lib-tk/turtle.pyo
-lib/python2.7/lib2to3/Grammar%%PORTVERSION%%.final.0.pickle
+lib/python2.7/lib2to3/Grammar%%DISTVERSION%%.final.0.pickle
lib/python2.7/lib2to3/Grammar.txt
-lib/python2.7/lib2to3/PatternGrammar%%PORTVERSION%%.final.0.pickle
+lib/python2.7/lib2to3/PatternGrammar%%DISTVERSION%%.final.0.pickle
lib/python2.7/lib2to3/PatternGrammar.txt
lib/python2.7/lib2to3/__init__.py
lib/python2.7/lib2to3/__init__.pyc
diff --git a/lang/python36/Makefile b/lang/python36/Makefile
index 0434c86a5698..636f8d198350 100644
--- a/lang/python36/Makefile
+++ b/lang/python36/Makefile
@@ -1,11 +1,11 @@
# Created by: Kubilay Kocak <koobs@FreeBSD.org>
PORTNAME= python
-PORTVERSION= ${PYTHON_PORTVERSION}
+DISTVERSION= ${PYTHON_DISTVERSION}
CATEGORIES= lang python
-MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
+MASTER_SITES= PYTHON/ftp/python/${DISTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
-DISTNAME= Python-${PORTVERSION}
+DISTNAME= Python-${DISTVERSION}
DIST_SUBDIR= python
# Resolve sinpi name clash with libm (IEEE-754 violation)
@@ -22,11 +22,11 @@ USES= cpe ncurses pathfix pkgconfig readline shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-python_CMD= ${PREFIX}/bin/python${PYTHON_PORTVERSION:R}
+python_CMD= ${PREFIX}/bin/python${PYTHON_DISTVERSION:R}
SHEBANG_FILES= Lib/*.py Lib/*/*.py Lib/*/*/*.py Lib/*/*/*/*.py
# Duplicate python.mk variables. TODO: Let lang/python?? ports use python.mk bits.
-PYTHON_VER= ${PYTHON_PORTVERSION:R}
+PYTHON_VER= ${PYTHON_DISTVERSION:R}
PYTHON_VERSION= python${PYTHON_VER}
PYTHON_SUFFIX= ${PYTHON_VER:S/.//g}
@@ -47,7 +47,7 @@ SUB_LIST= PYTHON_SUFFIX=${PYTHON_SUFFIX}
PLIST_SUB= ABI=${ABIFLAGS} \
XY=${PYTHON_SUFFIX} \
XYDOT=${PYTHON_VER} \
- XYZDOT=${PORTVERSION} \
+ XYZDOT=${DISTVERSION} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. https://bugs.python.org/issue19554
OPTIONS_DEFINE= DEBUG IPV6 LIBFFI NLS PYMALLOC THREADS
diff --git a/lang/python36/Makefile.version b/lang/python36/Makefile.version
index 6b04ea99a6cd..1e403b3d87d7 100644
--- a/lang/python36/Makefile.version
+++ b/lang/python36/Makefile.version
@@ -2,4 +2,4 @@
# Do not forget to update python documentation (lang/python-doc-*)
# Run "make -C lang/python-doc-html makesum"
-PYTHON_PORTVERSION= 3.6.13
+PYTHON_DISTVERSION= 3.6.13
diff --git a/lang/python37/Makefile b/lang/python37/Makefile
index e83ef0fc6abf..d95dc23b192a 100644
--- a/lang/python37/Makefile
+++ b/lang/python37/Makefile
@@ -1,12 +1,12 @@
# Created by: Kubilay Kocak <koobs@FreeBSD.org>
PORTNAME= python
-PORTVERSION= ${PYTHON_PORTVERSION}
+DISTVERSION= ${PYTHON_DISTVERSION}
PORTREVISION= 1
CATEGORIES= lang python
-MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
+MASTER_SITES= PYTHON/ftp/python/${DISTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
-DISTNAME= Python-${PORTVERSION}
+DISTNAME= Python-${DISTVERSION}
DIST_SUBDIR= python
MAINTAINER= python@FreeBSD.org
@@ -21,11 +21,11 @@ USES= cpe ncurses pathfix pkgconfig readline shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-python_CMD= ${PREFIX}/bin/python${PYTHON_PORTVERSION:R}
+python_CMD= ${PREFIX}/bin/python${PYTHON_DISTVERSION:R}
SHEBANG_FILES= Lib/*.py Lib/*/*.py Lib/*/*/*.py Lib/*/*/*/*.py
# Duplicate python.mk variables. TODO: Let lang/python?? ports use python.mk bits.
-PYTHON_VER= ${PYTHON_PORTVERSION:R}
+PYTHON_VER= ${PYTHON_DISTVERSION:R}
PYTHON_VERSION= python${PYTHON_VER}
PYTHON_SUFFIX= ${PYTHON_VER:S/.//g}
@@ -46,7 +46,7 @@ SUB_LIST= PYTHON_SUFFIX=${PYTHON_SUFFIX}
PLIST_SUB= ABI=${ABIFLAGS} \
XY=${PYTHON_SUFFIX} \
XYDOT=${PYTHON_VER} \
- XYZDOT=${PORTVERSION} \
+ XYZDOT=${DISTVERSION} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. https://bugs.python.org/issue19554
OPTIONS_DEFINE= DEBUG IPV6 NLS PYMALLOC
diff --git a/lang/python37/Makefile.version b/lang/python37/Makefile.version
index 0e41fc76aacc..043fc889c483 100644
--- a/lang/python37/Makefile.version
+++ b/lang/python37/Makefile.version
@@ -2,4 +2,4 @@
# Do not forget to update python documentation (lang/python-doc-*)
# Run "make -C lang/python-doc-html makesum"
-PYTHON_PORTVERSION= 3.7.10
+PYTHON_DISTVERSION= 3.7.10
diff --git a/lang/python38/Makefile b/lang/python38/Makefile
index ecc3e9ca22c1..be973fca11ac 100644
--- a/lang/python38/Makefile
+++ b/lang/python38/Makefile
@@ -1,11 +1,11 @@
# Created by: Kubilay Kocak <koobs@FreeBSD.org>
PORTNAME= python
-PORTVERSION= ${PYTHON_PORTVERSION}
+DISTVERSION= ${PYTHON_DISTVERSION}
CATEGORIES= lang python
-MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
+MASTER_SITES= PYTHON/ftp/python/${DISTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
-DISTNAME= Python-${PORTVERSION}
+DISTNAME= Python-${DISTVERSION}
DIST_SUBDIR= python
MAINTAINER= python@FreeBSD.org
@@ -17,14 +17,14 @@ USES= cpe ncurses pathfix pkgconfig readline shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-python_CMD= ${PREFIX}/bin/python${PYTHON_PORTVERSION:R}
+python_CMD= ${PREFIX}/bin/python${PYTHON_DISTVERSION:R}
SHEBANG_FILES= Lib/*.py Lib/*/*.py Lib/*/*/*.py Lib/*/*/*/*.py
SHEBANG_FILES+= Lib/test/ziptestdata/exe_with_z64 \
Lib/test/ziptestdata/exe_with_zip \
Lib/test/ziptestdata/header.sh
# Duplicate python.mk variables. TODO: Let lang/python?? ports use python.mk bits.
-PYTHON_VER= ${PYTHON_PORTVERSION:R}
+PYTHON_VER= ${PYTHON_DISTVERSION:R}
PYTHON_VERSION= python${PYTHON_VER}
PYTHON_SUFFIX= ${PYTHON_VER:S/.//g}
@@ -45,7 +45,7 @@ SUB_LIST= PYTHON_SUFFIX=${PYTHON_SUFFIX}
PLIST_SUB= ABI=${ABIFLAGS} \
XY=${PYTHON_SUFFIX} \
XYDOT=${PYTHON_VER} \
- XYZDOT=${PORTVERSION} \
+ XYZDOT=${DISTVERSION} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. https://bugs.python.org/issue19554
OPTIONS_DEFINE= DEBUG IPV6 LIBFFI LIBMPDEC NLS PYMALLOC
diff --git a/lang/python38/Makefile.version b/lang/python38/Makefile.version
index 12ed93354d24..7620495e8fc2 100644
--- a/lang/python38/Makefile.version
+++ b/lang/python38/Makefile.version
@@ -2,4 +2,4 @@
# Do not forget to update python documentation (lang/python-doc-*)
# Run "make -C lang/python-doc-html makesum"
-PYTHON_PORTVERSION= 3.8.10
+PYTHON_DISTVERSION= 3.8.10
diff --git a/lang/python39/Makefile b/lang/python39/Makefile
index 0bc868234c78..8a9b87d3c043 100644
--- a/lang/python39/Makefile
+++ b/lang/python39/Makefile
@@ -1,11 +1,11 @@
# Created by: Kubilay Kocak <koobs@FreeBSD.org>
PORTNAME= python
-PORTVERSION= ${PYTHON_PORTVERSION}
+DISTVERSION= ${PYTHON_DISTVERSION}
CATEGORIES= lang python
-MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
+MASTER_SITES= PYTHON/ftp/python/${DISTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
-DISTNAME= Python-${PORTVERSION}
+DISTNAME= Python-${DISTVERSION}
DIST_SUBDIR= python
MAINTAINER= python@FreeBSD.org
@@ -18,14 +18,14 @@ USES= compiler:c11 cpe ncurses pathfix pkgconfig readline \
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-python_CMD= ${PREFIX}/bin/python${PYTHON_PORTVERSION:R}
+python_CMD= ${PREFIX}/bin/python${PYTHON_DISTVERSION:R}
SHEBANG_FILES= Lib/*.py Lib/*/*.py Lib/*/*/*.py Lib/*/*/*/*.py
SHEBANG_FILES+= Lib/test/ziptestdata/exe_with_z64 \
Lib/test/ziptestdata/exe_with_zip \
Lib/test/ziptestdata/header.sh
# Duplicate python.mk variables. TODO: Let lang/python?? ports use python.mk bits.
-PYTHON_VER= ${PYTHON_PORTVERSION:R}
+PYTHON_VER= ${PYTHON_DISTVERSION:R}
PYTHON_VERSION= python${PYTHON_VER}
PYTHON_SUFFIX= ${PYTHON_VER:S/.//g}
@@ -46,7 +46,7 @@ SUB_LIST= PYTHON_SUFFIX=${PYTHON_SUFFIX}
PLIST_SUB= ABI=${ABIFLAGS} \
XY=${PYTHON_SUFFIX} \
XYDOT=${PYTHON_VER} \
- XYZDOT=${PORTVERSION} \
+ XYZDOT=${DISTVERSION} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. https://bugs.python.org/issue19554
OPTIONS_DEFINE= DEBUG IPV6 LIBFFI LIBMPDEC NLS PYMALLOC
diff --git a/lang/python39/Makefile.version b/lang/python39/Makefile.version
index 942af499f5f6..070b30dd33be 100644
--- a/lang/python39/Makefile.version
+++ b/lang/python39/Makefile.version
@@ -2,4 +2,4 @@
# Do not forget to update python documentation (lang/python-doc-*)
# Run "make -C lang/python-doc-html makesum"
-PYTHON_PORTVERSION= 3.9.5
+PYTHON_DISTVERSION= 3.9.5
diff --git a/lang/tauthon/Makefile b/lang/tauthon/Makefile
index aac57d6d7f5d..cd7f553f4dea 100644
--- a/lang/tauthon/Makefile
+++ b/lang/tauthon/Makefile
@@ -98,7 +98,7 @@ THREADS_LDFLAGS= -lpthread
UCS2_CONFIGURE_ENABLE= unicode=ucs2
UCS4_CONFIGURE_ENABLE= unicode=ucs4
-PYTHON_PORTVERSION= ${DISTVERSION}
+PYTHON_DISTVERSION= ${DISTVERSION}
VERSION_NOMICRO= ${DISTVERSION:R}
NAME_VERSION= tauthon${VERSION_NOMICRO}
diff --git a/x11-toolkits/py-tkinter/Makefile b/x11-toolkits/py-tkinter/Makefile
index 7be65a54bfbb..2d11f6a341f6 100644
--- a/x11-toolkits/py-tkinter/Makefile
+++ b/x11-toolkits/py-tkinter/Makefile
@@ -1,12 +1,12 @@
# Created by: Thomas Gellekum <tg@FreeBSD.org>
PORTNAME= tkinter
-PORTVERSION= ${PYTHON_PORTVERSION}
+DISTVERSION= ${PYTHON_DISTVERSION}
PORTREVISION= 6
CATEGORIES= x11-toolkits python
-MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
+MASTER_SITES= PYTHON/ftp/python/${DISTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= Python-${PORTVERSION}
+DISTNAME= Python-${DISTVERSION}
MAINTAINER= python@FreeBSD.org
COMMENT= Python bindings to the Tk widget set (Python ${PYTHON_VER})
@@ -20,7 +20,7 @@ USE_PYTHON= distutils autoplist allflavors
DIST_SUBDIR= python
DISTINFO_FILE= ${PORTSDIR}/lang/python${PYTHON_SUFFIX}/distinfo
-WRKSRC= ${WRKDIR}/Python-${PORTVERSION}/Modules
+WRKSRC= ${WRKDIR}/Python-${DISTVERSION}/Modules
PYDISTUTILS_INSTALLARGS+= --install-lib ${PYTHON_LIBDIR}/lib-dynload