aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-09-13 07:51:18 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-09-13 07:51:22 +0000
commit5f865db0d5f1b47f30d4b0a8617057ddddb8b542 (patch)
treec2406f22a2f61d69940c40f77341d63afbb1972e
parent9c0c366ceeb87df53f8a9e0aceaff216e614f038 (diff)
downloadports-5f865db0d5f1b47f30d4b0a8617057ddddb8b542.tar.gz
ports-5f865db0d5f1b47f30d4b0a8617057ddddb8b542.zip
devel/ocaml-uchar: new port had been added (+)
The uchar package provides a compatibility library for the Uchar module introduced in OCaml 4.03. WWW: https://ocaml.github.io/uchar/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ocaml-uchar/Makefile33
-rw-r--r--devel/ocaml-uchar/distinfo3
-rw-r--r--devel/ocaml-uchar/pkg-descr4
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8f07e9d2b473..6048b5222fee 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1630,6 +1630,7 @@
SUBDIR += ocaml-sem
SUBDIR += ocaml-sexplib
SUBDIR += ocaml-type_conv
+ SUBDIR += ocaml-uchar
SUBDIR += ocaml-ulex
SUBDIR += ocaml-uutf
SUBDIR += ocaml-xstr
diff --git a/devel/ocaml-uchar/Makefile b/devel/ocaml-uchar/Makefile
new file mode 100644
index 000000000000..5ad22ef9c183
--- /dev/null
+++ b/devel/ocaml-uchar/Makefile
@@ -0,0 +1,33 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+
+PORTNAME= uchar
+PORTVERSION= 0.0.2
+DISTVERSIONPREFIX= v
+CATEGORIES= devel
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Compatibility library for OCaml's Uchar module
+
+LICENSE= LGPL21 # (with linking exception)
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ocamlbuild:devel/ocaml-ocamlbuild \
+ opam-installer:devel/ocaml-opam
+
+USE_GITHUB= yes
+GH_ACCOUNT= ocaml
+USE_OCAML= yes
+
+PLIST_FILES= ${OCAML_SITELIBDIR}/${PORTNAME}/META
+
+do-build:
+ cd ${BUILD_WRKSRC} && ocaml pkg/build.ml \
+ native=true native-dynlink=true
+
+do-install:
+ cd ${INSTALL_WRKSRC} && opam-installer -i \
+ --prefix=${STAGEDIR}${PREFIX} \
+ --libdir=${OCAML_SITELIBDIR} ${PORTNAME}.install
+
+.include <bsd.port.mk>
diff --git a/devel/ocaml-uchar/distinfo b/devel/ocaml-uchar/distinfo
new file mode 100644
index 000000000000..25c66dbc82f0
--- /dev/null
+++ b/devel/ocaml-uchar/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1500157486
+SHA256 (ocaml-uchar-v0.0.2_GH0.tar.gz) = 17ed7574c3244db9885903d4936d43d9fa3944b5e9330a3ebdb0bffceb694903
+SIZE (ocaml-uchar-v0.0.2_GH0.tar.gz) = 21815
diff --git a/devel/ocaml-uchar/pkg-descr b/devel/ocaml-uchar/pkg-descr
new file mode 100644
index 000000000000..5305d01d7ef0
--- /dev/null
+++ b/devel/ocaml-uchar/pkg-descr
@@ -0,0 +1,4 @@
+The uchar package provides a compatibility library for the Uchar module
+introduced in OCaml 4.03.
+
+WWW: https://ocaml.github.io/uchar/