aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-19 16:29:48 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-19 17:18:32 +0000
commit5f95f20d4418546741a3e04ea731afe55cc4c01b (patch)
tree194c6220ef20a093124652d072e0fee0e13ce360
parentd1661af5ffd5362cd06805fa06d9cea600cbab37 (diff)
downloadports-5f95f20d4418546741a3e04ea731afe55cc4c01b.tar.gz
ports-5f95f20d4418546741a3e04ea731afe55cc4c01b.zip
misc/py-instructor: Allow build with py-typer 0.10.0+
- Bump PORTREVISION for package change Obtained from: https://github.com/jxnl/instructor/commit/c6273700c9ef7eea4acb88ac9eebb559d300a6a2 Approved by: tagattie (maintainer, via private mail)
-rw-r--r--misc/py-instructor/Makefile3
-rw-r--r--misc/py-instructor/files/patch-pyproject.toml13
2 files changed, 15 insertions, 1 deletions
diff --git a/misc/py-instructor/Makefile b/misc/py-instructor/Makefile
index fe99d271b042..ff825e0c3b57 100644
--- a/misc/py-instructor/Makefile
+++ b/misc/py-instructor/Makefile
@@ -1,5 +1,6 @@
PORTNAME= instructor
DISTVERSION= 0.4.8
+PORTREVISION= 1
CATEGORIES= misc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,7 +16,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>0:devel/py-poetry-core@${PY_FL
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openai>=1.1.0<2.0.0:misc/py-openai@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pydantic2>=2.0.2<3.0.0:devel/py-pydantic2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}docstring-parser>=0.15<0.16:textproc/py-docstring-parser@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}typer>=0.9.0<0.10.0:devel/py-typer@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typer>=0.9.0<1.0.0:devel/py-typer@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}rich>=13.7.0<14.0.0:textproc/py-rich@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}aiohttp>=3.9.1<4.0.0:www/py-aiohttp@${PY_FLAVOR}
diff --git a/misc/py-instructor/files/patch-pyproject.toml b/misc/py-instructor/files/patch-pyproject.toml
new file mode 100644
index 000000000000..b5a7f6a310c0
--- /dev/null
+++ b/misc/py-instructor/files/patch-pyproject.toml
@@ -0,0 +1,13 @@
+Obtained from: https://github.com/jxnl/instructor/commit/c6273700c9ef7eea4acb88ac9eebb559d300a6a2
+
+--- pyproject.toml.orig 2024-01-23 17:39:46 UTC
++++ pyproject.toml
+@@ -13,7 +13,7 @@ docstring-parser = "^0.15"
+ openai = "^1.1.0"
+ pydantic = "^2.0.2"
+ docstring-parser = "^0.15"
+-typer = "^0.9.0"
++typer = ">=0.9.0,<1.0.0"
+ rich = "^13.7.0"
+ aiohttp = "^3.9.1"
+