aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-02-28 18:00:52 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-02-28 18:38:32 +0000
commit601ebcdc2ba0418f9377e2962e5836964841bdb1 (patch)
tree6cc98a8dddcc5a25ac0ea46fc036cdd80b560657
parentd07be3c6bd0998950d9618f7ac6930bfbdf1ee20 (diff)
downloadports-601ebcdc2ba0418f9377e2962e5836964841bdb1.tar.gz
ports-601ebcdc2ba0418f9377e2962e5836964841bdb1.zip
devel/py-setuptools-rust: Add py-setuptools-rust 1.1.2
setuptools-rust is a plugin for setuptools to build Rust Python extensions implemented with PyO3 or rust-cpython. Compile and distribute Python extensions written in Rust as easily as if they were written in C. WWW: https://github.com/PyO3/setuptools-rust
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-setuptools-rust/Makefile25
-rw-r--r--devel/py-setuptools-rust/distinfo3
-rw-r--r--devel/py-setuptools-rust/pkg-descr7
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e1254f839d59..3aac3206109f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5235,6 +5235,7 @@
SUBDIR += py-setuptools
SUBDIR += py-setuptools-git
SUBDIR += py-setuptools-pkg
+ SUBDIR += py-setuptools-rust
SUBDIR += py-setuptools44
SUBDIR += py-setuptools_hg
SUBDIR += py-setuptools_scm
diff --git a/devel/py-setuptools-rust/Makefile b/devel/py-setuptools-rust/Makefile
new file mode 100644
index 000000000000..2126872532fe
--- /dev/null
+++ b/devel/py-setuptools-rust/Makefile
@@ -0,0 +1,25 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= setuptools-rust
+PORTVERSION= 1.1.2
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Setuptools Rust extension plugin
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=6.3.2:devel/py-setuptools_scm@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}semantic-version>=2.8.2<3:devel/py-semantic-version@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.7.4.3:devel/py-typing-extensions@${PY_FLAVOR} \
+ cargo:lang/rust
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-setuptools-rust/distinfo b/devel/py-setuptools-rust/distinfo
new file mode 100644
index 000000000000..a6b89648981e
--- /dev/null
+++ b/devel/py-setuptools-rust/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1644138500
+SHA256 (setuptools-rust-1.1.2.tar.gz) = a0adb9b503c0ffc4e8fe80b7c617898cefa78049983aaaea7f747e153a3e65d1
+SIZE (setuptools-rust-1.1.2.tar.gz) = 285260
diff --git a/devel/py-setuptools-rust/pkg-descr b/devel/py-setuptools-rust/pkg-descr
new file mode 100644
index 000000000000..59f2021c179a
--- /dev/null
+++ b/devel/py-setuptools-rust/pkg-descr
@@ -0,0 +1,7 @@
+setuptools-rust is a plugin for setuptools to build Rust Python extensions
+implemented with PyO3 or rust-cpython.
+
+Compile and distribute Python extensions written in Rust as easily as if they
+were written in C.
+
+WWW: https://github.com/PyO3/setuptools-rust