aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephane D'Alu <sdalu@sdalu.com>2023-10-27 10:07:05 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-11-07 00:17:18 +0000
commit60e76a989837d017855e4ffbf08c47bdc81734d1 (patch)
tree889e86d41f8303765fcd5c1ac1cca66ac4e27491
parent485abb2b09a4425e5e5fec868f94c329fadb67b8 (diff)
downloadports-60e76a989837d017855e4ffbf08c47bdc81734d1.tar.gz
ports-60e76a989837d017855e4ffbf08c47bdc81734d1.zip
games/libretro-beetle_psx: update to 0.20231020
PR: 274647
-rw-r--r--games/libretro-beetle_psx/Makefile9
-rw-r--r--games/libretro-beetle_psx/distinfo6
-rw-r--r--games/libretro-beetle_psx/files/patch-deps_lightning_lib_jit__arm-swf.c20
-rw-r--r--games/libretro-beetle_psx/files/patch-libretro-common_rthreads_rthreads.c10
4 files changed, 12 insertions, 33 deletions
diff --git a/games/libretro-beetle_psx/Makefile b/games/libretro-beetle_psx/Makefile
index f39260e485cc..b93a25799ab2 100644
--- a/games/libretro-beetle_psx/Makefile
+++ b/games/libretro-beetle_psx/Makefile
@@ -1,6 +1,5 @@
PORTNAME= libretro-beetle_psx
-PORTVERSION= 0.20220211
-PORTREVISION= 2
+DISTVERSION= 0.20231020
CATEGORIES= games
MAINTAINER= ports@FreeBSD.org
@@ -16,7 +15,7 @@ USE_GL= gl
USE_GITHUB= yes
GH_ACCOUNT= libretro
GH_PROJECT= beetle-psx-libretro
-GH_TAGNAME= 88929ae
+GH_TAGNAME= e505f5a93eebba8f96a040f478d77b6ffb2015b1
PLIST_FILES= lib/libretro/mednafen_psx_libretro.so
@@ -27,7 +26,7 @@ USE_GCC= yes:build
.endif
do-install:
- ${MKDIR} ${STAGEDIR}/${PREFIX}/lib/libretro;
- ${INSTALL_LIB} ${WRKSRC}/mednafen_psx_libretro.so ${STAGEDIR}/${PREFIX}/lib/libretro;
+ ${MKDIR} ${STAGEDIR}/${PREFIX}/lib/libretro
+ ${INSTALL_LIB} ${WRKSRC}/mednafen_psx_libretro.so ${STAGEDIR}/${PREFIX}/lib/libretro
.include <bsd.port.post.mk>
diff --git a/games/libretro-beetle_psx/distinfo b/games/libretro-beetle_psx/distinfo
index ed80053b9f95..ebcff25d35e4 100644
--- a/games/libretro-beetle_psx/distinfo
+++ b/games/libretro-beetle_psx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1649322970
-SHA256 (libretro-beetle-psx-libretro-0.20220211-88929ae_GH0.tar.gz) = f9397a131b27505bc2a6912b26913af713fe492da6b6b1e2ade779be25359657
-SIZE (libretro-beetle-psx-libretro-0.20220211-88929ae_GH0.tar.gz) = 2830532
+TIMESTAMP = 1698314797
+SHA256 (libretro-beetle-psx-libretro-0.20231020-e505f5a93eebba8f96a040f478d77b6ffb2015b1_GH0.tar.gz) = c1c142439dd5476450b02653acbf63d2e380fe31842a3319edf061072f6bf74d
+SIZE (libretro-beetle-psx-libretro-0.20231020-e505f5a93eebba8f96a040f478d77b6ffb2015b1_GH0.tar.gz) = 2763577
diff --git a/games/libretro-beetle_psx/files/patch-deps_lightning_lib_jit__arm-swf.c b/games/libretro-beetle_psx/files/patch-deps_lightning_lib_jit__arm-swf.c
deleted file mode 100644
index 6e2cdfe00c4e..000000000000
--- a/games/libretro-beetle_psx/files/patch-deps_lightning_lib_jit__arm-swf.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- deps/lightning/lib/jit_arm-swf.c.orig 2022-11-30 10:43:45 UTC
-+++ deps/lightning/lib/jit_arm-swf.c
-@@ -402,7 +402,7 @@ static void _swf_vaarg_d(jit_state_t*, jit_int32_t, ji
- BICI(rt, rn, encode_arm_immediate(im)); \
- } while (0)
-
--#if !defined(__GNUC__)
-+#if !defined(__GNUC__) || defined(__llvm__)
- float __addsf3(float u, float v)
- {
- return (u + v);
-@@ -414,6 +414,8 @@ __adddf3(double u, double v)
- return (u + v);
- }
-
-+#endif
-+#if !defined(__GNUC__)
- float
- __aeabi_fsub(float u, float v)
- {
diff --git a/games/libretro-beetle_psx/files/patch-libretro-common_rthreads_rthreads.c b/games/libretro-beetle_psx/files/patch-libretro-common_rthreads_rthreads.c
index 0ca1ab3d9c0b..aea08c49a422 100644
--- a/games/libretro-beetle_psx/files/patch-libretro-common_rthreads_rthreads.c
+++ b/games/libretro-beetle_psx/files/patch-libretro-common_rthreads_rthreads.c
@@ -1,11 +1,11 @@
---- libretro-common/rthreads/rthreads.c.orig 2020-03-17 21:58:04 UTC
+--- libretro-common/rthreads/rthreads.c.orig 2023-10-30 09:18:10 UTC
+++ libretro-common/rthreads/rthreads.c
-@@ -58,6 +58,8 @@
+@@ -56,7 +56,7 @@
#include <time.h>
#endif
-+#include <sys/time.h>
-+
- #if defined(VITA) || defined(BSD) || defined(ORBIS)
+-#if defined(VITA) || defined(BSD) || defined(ORBIS) || defined(__mips__) || defined(_3DS)
++#if defined(VITA) || defined(BSD) || defined(ORBIS) || defined(__mips__) || defined(_3DS) || (__FreeBSD__ <= 12)
#include <sys/time.h>
#endif
+