aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-09 13:44:45 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-09 14:05:18 +0000
commit60f13636769964bbf5697d2e60e2348c4a179ccc (patch)
tree8a6e695f391f0d6a269804274579b31412e1c394
parent724c9182c58d65e29f2b29ec64814c9894c536f0 (diff)
downloadports-60f13636769964bbf5697d2e60e2348c4a179ccc.tar.gz
ports-60f13636769964bbf5697d2e60e2348c4a179ccc.zip
devel/bpython: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--devel/bpython/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/bpython/Makefile b/devel/bpython/Makefile
index e8280ddd4508..0fe5cbee799c 100644
--- a/devel/bpython/Makefile
+++ b/devel/bpython/Makefile
@@ -1,5 +1,6 @@
PORTNAME= bpython
PORTVERSION= 0.24
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI \
https://bpython-interpreter.org/releases/
@@ -12,7 +13,9 @@ WWW= https://bpython-interpreter.org/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=1.1.3,1:textproc/py-sphinx@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=43:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx>=1.1.3,1:textproc/py-sphinx@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}curtsies>=0.4.0:devel/py-curtsies@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cwcwidth>=0:devel/py-cwcwidth@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}greenlet>=0:devel/py-greenlet@${PY_FLAVOR} \
@@ -21,7 +24,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}curtsies>=0.4.0:devel/py-curtsies@${PY_FLAVO
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes