aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2024-01-18 22:54:21 +0000
committerMikhail Teterin <mi@FreeBSD.org>2024-01-18 22:54:21 +0000
commit6120c446784035dbbf34051ed87c8269c1abd434 (patch)
treeb12ef8ad8d565dcf9dd4472c0927bf311954b001
parent80682e2c6b3219c26707ff76f2a219957b3b232f (diff)
downloadports-6120c446784035dbbf34051ed87c8269c1abd434.tar.gz
ports-6120c446784035dbbf34051ed87c8269c1abd434.zip
net/openldap26-server: relax OpenSSL version requirement
The authors' configure insists on OpenSSL-1.1.1, but the software makes no use of the new features -- and can compile just as well against the older OpenSSL. Also remove patch-configure -- the freshly patch configure script was being overwritten anyway by the autoconf. PR: 276388
-rw-r--r--net/openldap26-server/files/patch-configure32
-rw-r--r--net/openldap26-server/files/patch-configure.ac16
2 files changed, 16 insertions, 32 deletions
diff --git a/net/openldap26-server/files/patch-configure b/net/openldap26-server/files/patch-configure
deleted file mode 100644
index 97d8af90e78e..000000000000
--- a/net/openldap26-server/files/patch-configure
+++ /dev/null
@@ -1,32 +0,0 @@
---- configure.orig 2021-07-27 17:44:47 UTC
-+++ configure
-@@ -16827,9 +16827,9 @@ $as_echo "#define HAVE_UUID_TO_STR 1" >>confdefs.h
- fi
-
- if test $have_uuid = no ; then
-- for ac_header in uuid/uuid.h
-+ for ac_header in xxuuid/uuid.h
- do :
-- ac_fn_c_check_header_mongrel "$LINENO" "uuid/uuid.h" "ac_cv_header_uuid_uuid_h" "$ac_includes_default"
-+ ac_fn_c_check_header_mongrel "$LINENO" "xxuuid/uuid.h" "ac_cv_header_uuid_uuid_h" "$ac_includes_default"
- if test "x$ac_cv_header_uuid_uuid_h" = xyes; then :
- cat >>confdefs.h <<_ACEOF
- #define HAVE_UUID_UUID_H 1
-@@ -22127,7 +22127,7 @@ if ${ac_cv_lib_iodbc_SQLDriverConnect+:} false; then :
- $as_echo_n "(cached) " >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-liodbc $LIBS"
-+LIBS="-liodbc $LIBS $LTHREAD_LIBS"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h. */
-
-@@ -22175,7 +22175,7 @@ if ${ac_cv_lib_odbc_SQLDriverConnect+:} false; then :
- $as_echo_n "(cached) " >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lodbc $LIBS"
-+LIBS="-lodbc $LIBS $LTHREAD_LIBS"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h. */
-
diff --git a/net/openldap26-server/files/patch-configure.ac b/net/openldap26-server/files/patch-configure.ac
new file mode 100644
index 000000000000..034007b89d70
--- /dev/null
+++ b/net/openldap26-server/files/patch-configure.ac
@@ -0,0 +1,16 @@
+--- configure.ac 2023-07-31 14:09:15.000000000 -0400
++++ configure.ac 2024-01-16 15:17:17.855596000 -0500
+@@ -1225,11 +1225,11 @@
+ if test $ac_cv_header_openssl_ssl_h = yes ; then
+ AC_PREPROC_IFELSE([AC_LANG_SOURCE(
+ [[#include <openssl/opensslv.h>]
+-[#if OPENSSL_VERSION_NUMBER < 0x1010100fL]
++[#if OPENSSL_VERSION_NUMBER < 0x1000215fL]
+ [#error "OpenSSL is too old"]
+ [#endif]])],
+ , [AC_MSG_FAILURE([OpenSSL 1.1.1 or newer required])])
+
+- AC_CHECK_LIB(ssl, SSL_CTX_set_ciphersuites,
++ AC_CHECK_LIB(ssl, SSL_CTX_new,
+ [have_openssl=yes], [have_openssl=no],
+ [-lcrypto])