aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-06-03 11:15:22 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-06-03 11:34:03 +0000
commit618cb4a87e8f811e54889cd353f59847f8b55ba3 (patch)
tree305e0ba199180725d68bc4c4ddccca7071cc838a
parentece647d08c3933df136bef37559c6987eec192a7 (diff)
downloadports-618cb4a87e8f811e54889cd353f59847f8b55ba3.tar.gz
ports-618cb4a87e8f811e54889cd353f59847f8b55ba3.zip
www/py-aiohttp: update to 3.7.4.post0
PR: 256219 Approved by: koobs (maintainer) Security: CVE-2021-21330 Security: 3000acee-c45d-11eb-904f-14dae9d5a9d2 MFH: 2020Q2 (bugfix, security release(s)) (cherry picked from commit ac412b55156cc77c8e96fb631a338a617749bcb7)
-rw-r--r--www/py-aiohttp/Makefile10
-rw-r--r--www/py-aiohttp/distinfo6
-rw-r--r--www/py-aiohttp/files/patch-setup.py27
3 files changed, 8 insertions, 35 deletions
diff --git a/www/py-aiohttp/Makefile b/www/py-aiohttp/Makefile
index 844db37039d8..2861ac41cae7 100644
--- a/www/py-aiohttp/Makefile
+++ b/www/py-aiohttp/Makefile
@@ -13,10 +13,11 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}attrs>=17.3.0:devel/py-attrs@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}chardet>=2.0<4.0,1:textproc/py-chardet@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}multidict>=4.5:www/py-multidict@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}chardet>=2.0<5.0,1:textproc/py-chardet@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}multidict>=4.5<7.0:www/py-multidict@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}async_timeout>=3.0<4.0:devel/py-async_timeout@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}yarl>=1.0<2.0:www/py-yarl@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}yarl>=1.0<2.0:www/py-yarl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.6.5:devel/py-typing-extensions@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.8.2:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-timeout>0:devel/py-pytest-timeout@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-xdist>0:devel/py-pytest-xdist@${PY_FLAVOR} \
@@ -29,8 +30,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.8.2:devel/py-pytest@${PY_FLAVOR}
# to be ported ${PYTHON_PKGNAMEPREFIX}brotlypy>0:archivers/py-brotlipy@${PY_FLAVOR}
# to be ported ${PYTHON_PKGNAMEPREFIX}trustme>0:security/py-trustme@${PY_FLAVOR}
-# Actually 3.5.3+
-USES= python:3.5+
+USES= python:3.6+
USE_PYTHON= autoplist distutils cython
.include <bsd.port.pre.mk>
diff --git a/www/py-aiohttp/distinfo b/www/py-aiohttp/distinfo
index 0017b66c2c50..5bc629fa4f89 100644
--- a/www/py-aiohttp/distinfo
+++ b/www/py-aiohttp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1592851297
-SHA256 (aiohttp-3.6.2.tar.gz) = 259ab809ff0727d0e834ac5e8a283dc5e3e0ecc30c4d80b3cd17a4139ce1f326
-SIZE (aiohttp-3.6.2.tar.gz) = 1076923
+TIMESTAMP = 1622602368
+SHA256 (aiohttp-3.7.4.post0.tar.gz) = 493d3299ebe5f5a7c66b9819eacdcfbbaaf1a8e84911ddffcdc48888497afecf
+SIZE (aiohttp-3.7.4.post0.tar.gz) = 1114888
diff --git a/www/py-aiohttp/files/patch-setup.py b/www/py-aiohttp/files/patch-setup.py
deleted file mode 100644
index e2525df64be9..000000000000
--- a/www/py-aiohttp/files/patch-setup.py
+++ /dev/null
@@ -1,27 +0,0 @@
-Obtained from: https://github.com/aio-libs/aiohttp/commit/d7db1b90c59ae49660d5b469f6186d088a6d190d
-
---- setup.py.orig 2019-10-09 16:52:31 UTC
-+++ setup.py
-@@ -74,7 +74,7 @@ except IndexError:
- install_requires = [
- 'attrs>=17.3.0',
- 'chardet>=2.0,<4.0',
-- 'multidict>=4.5,<5.0',
-+ 'multidict>=4.5,<6.0',
- 'async_timeout>=3.0,<4.0',
- 'yarl>=1.0,<2.0',
- 'idna-ssl>=1.0; python_version<"3.7"',
-@@ -104,9 +104,12 @@ NEEDS_PYTEST = {'pytest', 'test'}.intersection(sys.arg
- pytest_runner = ['pytest-runner'] if NEEDS_PYTEST else []
-
- tests_require = [
-- 'pytest', 'gunicorn',
-+ 'pytest>=3.8.2', 'gunicorn',
- 'pytest-timeout', 'async-generator',
- 'pytest-xdist',
-+ 'pytest-mock',
-+ 'trustme',
-+ 'brotlipy',
- ]
-
-