aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2021-09-14 10:52:14 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2021-09-14 10:53:18 +0000
commit6198006bca7ff681f433863cf1bbba3c225fbca0 (patch)
tree64e9e356783ca5e842a813cde8aa45bc4c0103f8
parent1fec92b6c26a3680ed11f35faac0b091928c5347 (diff)
downloadports-6198006bca7ff681f433863cf1bbba3c225fbca0.tar.gz
ports-6198006bca7ff681f433863cf1bbba3c225fbca0.zip
ports-mgmt/pkg-devel: Fix package when SAN is on
There is no pkg-static when SAN is on but the framework needs it. So just ln pkg-static to pkg.
-rw-r--r--ports-mgmt/pkg-devel/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/ports-mgmt/pkg-devel/Makefile b/ports-mgmt/pkg-devel/Makefile
index 4094f611af20..b59c13f584c5 100644
--- a/ports-mgmt/pkg-devel/Makefile
+++ b/ports-mgmt/pkg-devel/Makefile
@@ -75,5 +75,9 @@ post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/compat/pkg
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/NEWS ${STAGEDIR}${DOCSDIR}/NEWS
+.if ${PORT_OPTIONS:MSAN}
+ @(cd ${STAGEDIR}${PREFIX}/sbin/ && \
+ ${LN} -fs pkg pkg-static)
+.endif
.include <bsd.port.post.mk>