aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Hein <jcfyecrayz@liamekaens.com>2023-09-30 21:41:46 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-10-04 20:04:13 +0000
commit61b5d46f2faf578738ba2a4539b95adf0615dac2 (patch)
treea37a58f259aeab3e9ef659d99ea1aabd6c800615
parent472789f5d551e6a8cb5f36f1d38dd1cc5d95d1b0 (diff)
downloadports-61b5d46f2faf578738ba2a4539b95adf0615dac2.tar.gz
ports-61b5d46f2faf578738ba2a4539b95adf0615dac2.zip
security/tpm2-tools: fix build if security/openssl is installed
If someone has DEFAULT_VERSIONS=ssl:openssl it will now check the lib in /usr/local during configure. Similarly if using DEFAULT_VERSIONS=ssl:base, it looks in /usr/lib during configure. PR: 274013 Approved by: tstruk@gmail.com (maintainer) MFH: 2023Q4 (cherry picked from commit a4f11eab468a6e3741cb8cdced5660634917120e)
-rw-r--r--security/tpm2-tools/Makefile1
-rw-r--r--security/tpm2-tools/files/patch-configure20
2 files changed, 21 insertions, 0 deletions
diff --git a/security/tpm2-tools/Makefile b/security/tpm2-tools/Makefile
index 0f226e79b755..4bf8a905e7bd 100644
--- a/security/tpm2-tools/Makefile
+++ b/security/tpm2-tools/Makefile
@@ -1,5 +1,6 @@
PORTNAME= tpm2-tools
DISTVERSION= 5.5
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= https://github.com/tpm2-software/tpm2-tools/releases/download/${DISTVERSION}/
diff --git a/security/tpm2-tools/files/patch-configure b/security/tpm2-tools/files/patch-configure
new file mode 100644
index 000000000000..32381edd529c
--- /dev/null
+++ b/security/tpm2-tools/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig 2023-02-13 15:09:39 UTC
++++ configure
+@@ -14030,7 +14030,7 @@ if ${ac_cv_lib_crypto_EVP_sm3+:} false; then :
+ $as_echo_n "(cached) " >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lcrypto $LIBS"
++LIBS="${CRYPTO_LIBS} $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -14073,7 +14073,7 @@ if ${ac_cv_lib_crypto_EVP_sm4_cfb128+:} false; then :
+ $as_echo_n "(cached) " >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lcrypto $LIBS"
++LIBS="${CRYPTO_LIBS} $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+