aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2024-01-30 20:12:23 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2024-01-30 20:22:18 +0000
commit61c50fc367406d43f488425d4e0fee1e33a3a298 (patch)
treedeebd8762d40034a014e8cbc9d1cb80e6912d9f6
parent8ae871a44d440094c8936d4b0e41685fd8469f0b (diff)
downloadports-61c50fc367406d43f488425d4e0fee1e33a3a298.tar.gz
ports-61c50fc367406d43f488425d4e0fee1e33a3a298.zip
games/eboard: Move man to share/man
While here, also - correct comment - add print/harfbuzz dependency - add icon to DESKTOP_ENTRIES - strip to more binaries - bump PORTREVISION
-rw-r--r--games/eboard/Makefile18
-rw-r--r--games/eboard/files/patch-configure13
-rw-r--r--games/eboard/pkg-plist9
3 files changed, 19 insertions, 21 deletions
diff --git a/games/eboard/Makefile b/games/eboard/Makefile
index cdc69da3bff1..46639b4b1b23 100644
--- a/games/eboard/Makefile
+++ b/games/eboard/Makefile
@@ -1,7 +1,7 @@
PORTNAME= eboard
PORTVERSION= 1.1.3
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/eboard-extras/pack%201%20patchlevel%202/:p1 \
SF/${PORTNAME}/eboard-extras/pack%202/:p2
@@ -11,16 +11,18 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= rhurlin@FreeBSD.org
-COMMENT= GTK chess board interface (mainly for FICS and chessd)
+COMMENT= GTK+ chess board interface (mainly for FICS and chessd)
WWW= https://www.bergo.eng.br/eboard/
LICENSE= GPLv2
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
- libpng.so:graphics/png
+ libharfbuzz.so:print/harfbuzz \
+ libpng16.so:graphics/png
-USES= compiler:c++11-lang gnome gstreamer perl5 pkgconfig shebangfix tar:bzip2
+USES= compiler:c++11-lang gnome gstreamer perl5 pkgconfig \
+ shebangfix tar:bzip2
# eboard 1.1.13 is not compatible with C++17, which is the default since
# clang 16. This means ports depending on it also need to use at most C++14.
USE_CXXSTD= c++11
@@ -34,13 +36,14 @@ SHEBANG_FILES= configure
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--extra-inc=${LOCALBASE}/include \
- --extra-ld=${LOCALBASE}/lib
+ --extra-ld=${LOCALBASE}/lib \
+ --man-prefix=${PREFIX}/share/man
INSTALL_TARGET= install install-man
DESKTOP_ENTRIES="eboard" \
"Play chess" \
- "${PREFIX}/share/pixmaps/eboard.xpm" \
+ "${DATADIR}/gnupiece.xpm" \
"eboard" \
"Game;BoardGame;GTK;" \
true
@@ -63,6 +66,9 @@ pre-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/eboard
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/share/eboard/timeseal.FreeBSD
+ (cd ${WRKSRC}/xpm/ && ${CP} gnupiece.xpm ${STAGEDIR}${DATADIR})
# There is no timeseal port ATM :(
# @${LN} -sf ${LOCALBASE}/bin/timeseal \
# ${STAGEDIR}${DATADIR}/timeseal.FreeBSD
diff --git a/games/eboard/files/patch-configure b/games/eboard/files/patch-configure
index 66f7415044e9..ce82492413e3 100644
--- a/games/eboard/files/patch-configure
+++ b/games/eboard/files/patch-configure
@@ -1,14 +1,5 @@
---- configure.orig 2021-05-06 14:10:24 UTC
+--- configure.orig 2024-01-28 15:28:41 UTC
+++ configure
-@@ -106,7 +106,7 @@ sub run_cmd {
- }
-
- sub cplusplus_lang {
-- my @compilers = ( $cxx, 'g++', 'c++' );
-+ my @compilers = ( $cxx, 'g++10', 'c++' );
- my $x;
- my $program = <<EOF;
- #include <list>
@@ -357,7 +357,7 @@ sub header_check {
log_file("test.cc");
@@ -18,7 +9,7 @@
print ": no\n";
$y = header_def($x);
print CONFIGH "#undef $y\n";
-@@ -511,17 +511,9 @@ if (!header_check("stdio.h","stdlib.h","string.h","uni
+@@ -511,17 +511,9 @@ header_check("strings.h");
#optional headers
header_check("strings.h");
diff --git a/games/eboard/pkg-plist b/games/eboard/pkg-plist
index 6db8501d357a..a4be657f0304 100644
--- a/games/eboard/pkg-plist
+++ b/games/eboard/pkg-plist
@@ -1,9 +1,6 @@
bin/eboard
bin/eboard-addtheme
bin/eboard-config
-man/man1/eboard-config.1.gz
-man/man1/eboard-addtheme.1.gz
-man/man6/eboard.6.gz
%%PORTDOCS%%%%DOCSDIR%%/Crafty.txt
%%PORTDOCS%%%%DOCSDIR%%/FICS-Timeseal.txt
%%PORTDOCS%%%%DOCSDIR%%/GNUChess4.txt
@@ -65,9 +62,9 @@ man/man6/eboard.6.gz
%%DATADIR%%/eboard.de.dict
%%DATADIR%%/eboard.es.dict
%%DATADIR%%/eboard.fr.dict
+%%DATADIR%%/eboard.hu.dict
%%DATADIR%%/eboard.it.dict
%%DATADIR%%/eboard.ja.dict
-%%DATADIR%%/eboard.hu.dict
%%DATADIR%%/eboard.pl.dict
%%DATADIR%%/eboard.pt_BR.dict
%%DATADIR%%/eboard.zh_CN.dict
@@ -75,7 +72,11 @@ man/man6/eboard.6.gz
%%DATADIR%%/extras1.prevconf
%%DATADIR%%/extras2.prevconf
%%DATADIR%%/ghouls.png
+%%DATADIR%%/gnupiece.xpm
%%DATADIR%%/plastic.png
%%DATADIR%%/themeconf.extras1
%%DATADIR%%/themeconf.extras2
%%DATADIR%%/timeseal.FreeBSD
+share/man/man1/eboard-addtheme.1.gz
+share/man/man1/eboard-config.1.gz
+share/man/man6/eboard.6.gz