aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2024-06-19 11:26:46 +0000
committerThierry Thomas <thierry@FreeBSD.org>2024-06-21 20:18:10 +0000
commit62af3b140f21f4f1eaf7adb3b469d1d276927602 (patch)
tree3c79772af20b48134d690167480d55b1d401f6ed
parent1d0f5b57c9e5f63ad90ce9fa1fff06bda0293108 (diff)
downloadports-62af3b140f21f4f1eaf7adb3b469d1d276927602.tar.gz
ports-62af3b140f21f4f1eaf7adb3b469d1d276927602.zip
math/suitesparse: avoid mixing various BLAS/LAPACK libraries
When math/blas and math/atlas are installed on the same machine, it seems that they can be mixed, causing a CHOLMOD failure. PR: 279820 Reported by: gja822@narod.ru
-rw-r--r--math/suitesparse/bsd.suitesparse.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/math/suitesparse/bsd.suitesparse.mk b/math/suitesparse/bsd.suitesparse.mk
index cf3e5002f85d..5719f8b702b4 100644
--- a/math/suitesparse/bsd.suitesparse.mk
+++ b/math/suitesparse/bsd.suitesparse.mk
@@ -25,6 +25,8 @@ CONFIGURE_WRKSRC=${WRKSRC}/SuiteSparse_config
.endif
BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
CMAKE_SOURCE_PATH= ${CONFIGURE_WRKSRC}
+CMAKE_ARGS+= -DBLAS_LIBRARIES:STRING="${BLASLIB}" \
+ -DLAPACK_LIBRARIES:STRING="${LAPACKLIB}"
.if ${MPORTNAME} != config && \
${MPORTNAME} != CSparse && \