aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-07-13 18:28:36 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-07-13 22:44:45 +0000
commit631a439fecb874105df0a68b978a91b05f34f0b8 (patch)
tree8f079451f256ec45d0de711d79ce57d2b10b26bd
parent99c2d852228adf47ab84b0129b204ed5eea38ee4 (diff)
downloadports-631a439fecb874105df0a68b978a91b05f34f0b8.tar.gz
ports-631a439fecb874105df0a68b978a91b05f34f0b8.zip
devel/py-iopath: New Port: Library providing I/O interface among storage backends
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-iopath/Makefile22
-rw-r--r--devel/py-iopath/distinfo3
-rw-r--r--devel/py-iopath/pkg-descr4
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1841f6e72ab6..bff6a25dfcbb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4547,6 +4547,7 @@
SUBDIR += py-intervaltree
SUBDIR += py-invoke
SUBDIR += py-ioflo
+ SUBDIR += py-iopath
SUBDIR += py-ipaddr
SUBDIR += py-ipdb
SUBDIR += py-ipykernel5
diff --git a/devel/py-iopath/Makefile b/devel/py-iopath/Makefile
new file mode 100644
index 000000000000..45bc2ce3e897
--- /dev/null
+++ b/devel/py-iopath/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= iopath
+PORTVERSION= 0.1.9
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nc@FreeBSD.org
+COMMENT= Library providing I/O interface among storage backends
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}portalocker>0:devel/py-portalocker@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>0:misc/py-tqdm@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_GITHUB= yes
+GH_ACCOUNT= facebookresearch
+GH_TAGNAME= b49ef53b557b794ad142047905827a6727b91d63
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-iopath/distinfo b/devel/py-iopath/distinfo
new file mode 100644
index 000000000000..2659ae4a0367
--- /dev/null
+++ b/devel/py-iopath/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1626200732
+SHA256 (facebookresearch-iopath-0.1.9-b49ef53b557b794ad142047905827a6727b91d63_GH0.tar.gz) = d1ac38ab3c7842b394ac7b543434a9b4ca8c375af88d0df143abd1fe744768c2
+SIZE (facebookresearch-iopath-0.1.9-b49ef53b557b794ad142047905827a6727b91d63_GH0.tar.gz) = 35979
diff --git a/devel/py-iopath/pkg-descr b/devel/py-iopath/pkg-descr
new file mode 100644
index 000000000000..94f868546747
--- /dev/null
+++ b/devel/py-iopath/pkg-descr
@@ -0,0 +1,4 @@
+iopath is a lightweight I/O abstraction library that provides a common
+interface across storage backends.
+
+WWW: https://github.com/facebookresearch/iopath