aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2022-12-22 13:46:08 +0000
committerNicola Vitale <nivit@FreeBSD.org>2022-12-22 13:49:59 +0000
commit63476029ed362a75484925a4a3425517b262849b (patch)
tree4ef737875db2cd928a8e865f13031aa7f9ac77aa
parentefa0a000e7e004e49036f7310bcb79b7a6826c53 (diff)
downloadports-63476029ed362a75484925a4a3425517b262849b.tar.gz
ports-63476029ed362a75484925a4a3425517b262849b.zip
devel/py-wheel: Fix extraction when cross-building the port
Override EXTRACT_CMD and pass the variable LC_ALL to fix the extraction of the distfile. The build fails when cross-building the port with the following error: => SHA256 Checksum OK for wheel-0.38.4.tar.gz. tar: Pathname can't be converted from UTF-8 to current locale. tar: Error exit delayed from previous errors. PR: 268500 Reported by: <bas@area536.com>
-rw-r--r--devel/py-wheel/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/devel/py-wheel/Makefile b/devel/py-wheel/Makefile
index 63cb68486d24..ffee000b6db7 100644
--- a/devel/py-wheel/Makefile
+++ b/devel/py-wheel/Makefile
@@ -13,6 +13,8 @@ LICENSE= MIT
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
+# see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=268500
+EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
NO_ARCH= yes
OPTIONS_DEFINE= PIP SIGNATURE