aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2023-10-22 16:07:12 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2023-10-22 16:15:52 +0000
commit63ef7d1ab018109313476c9b03632c4fe1ab6633 (patch)
tree35f7f79453f9165a1ba11d62e2b49f042017cbae
parent24c2bf6b3cffe2dbff236e2776198b35d9c08356 (diff)
downloadports-63ef7d1ab018109313476c9b03632c4fe1ab6633.tar.gz
ports-63ef7d1ab018109313476c9b03632c4fe1ab6633.zip
emulators/wine-devel: Use GStreamer when supporting sound
When ALSA or OSS are enabled, i.e., we have sound enabled, pull in and use GStreamer as well. PR: 273987 Reported by: scf
-rw-r--r--emulators/wine-devel/Makefile10
-rw-r--r--emulators/wine-devel/pkg-plist4
2 files changed, 14 insertions, 0 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index ac8a54161728..83fb3fd338b6 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -81,6 +81,7 @@ GECKO_DESC= Bundle Gecko MSI package for Wine
MONO_DESC= Bundle Mono MSI package for Wine
ALSA_CONFIGURE_WITH= alsa
+ALSA_USES= gstreamer
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
ALSA_RUN_DEPENDS= alsa-plugins>0:audio/alsa-plugins
@@ -97,6 +98,7 @@ GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
MONO_RUN_DEPENDS= wine-mono-devel>0:emulators/wine-mono-devel
OSS_CONFIGURE_WITH= oss
+OSS_USES= gstreamer
V4L_CONFIGURE_WITH= v4l2
V4L_BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
@@ -113,6 +115,14 @@ X11_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
.include <bsd.port.pre.mk>
+.if ${PORT_OPTIONS:MALSA} || ${PORT_OPTIONS:MOSS}
+CONFIGURE_ARGS+= --with-gstreamer
+PLIST_SUB+= GSTREAMER=""
+.else
+CONFIGURE_ARGS+= --without-gstreamer
+PLIST_SUB+= GSTREAMER="@comment "
+.endif
+
.if (${LLVM_DEFAULT} == 10 || ${LLVM_DEFAULT} == 11)
_LLVM_VERSION= 15
.else
diff --git a/emulators/wine-devel/pkg-plist b/emulators/wine-devel/pkg-plist
index 36e82871ab0f..f310953a6e0d 100644
--- a/emulators/wine-devel/pkg-plist
+++ b/emulators/wine-devel/pkg-plist
@@ -1644,6 +1644,7 @@ lib/wine/%%WINEARCH%%-unix/libfaultrep.a
lib/wine/%%WINEARCH%%-unix/libgdi32.a
lib/wine/%%WINEARCH%%-unix/libgdiplus.a
lib/wine/%%WINEARCH%%-unix/libglu32.a
+%%GSTREAMER%%lib/wine/%%WINEARCH%%-unix/libwinegstreamer.a
lib/wine/%%WINEARCH%%-unix/libhal.a
lib/wine/%%WINEARCH%%-unix/libhid.a
lib/wine/%%WINEARCH%%-unix/libhidclass.a
@@ -2145,6 +2146,8 @@ lib/wine/%%WINEARCH%%-unix/wined3d.dll.so
lib/wine/%%WINEARCH%%-unix/winedbg.exe.so
lib/wine/%%WINEARCH%%-unix/winedevice.exe.so
lib/wine/%%WINEARCH%%-unix/winefile.exe.so
+%%GSTREAMER%%lib/wine/%%WINEARCH%%-unix/winegstreamer.dll.so
+%%GSTREAMER%%lib/wine/%%WINEARCH%%-unix/winegstreamer.so
lib/wine/%%WINEARCH%%-unix/winehid.sys.so
lib/wine/%%WINEARCH%%-unix/winemapi.dll.so
lib/wine/%%WINEARCH%%-unix/winemenubuilder.exe.so
@@ -2918,6 +2921,7 @@ lib/wine/%%WINEARCH%%-windows/wined3d.dll
lib/wine/%%WINEARCH%%-windows/winedbg.exe
lib/wine/%%WINEARCH%%-windows/winedevice.exe
lib/wine/%%WINEARCH%%-windows/winefile.exe
+%%GSTREAMER%%lib/wine/%%WINEARCH%%-windows/winegstreamer.dll
lib/wine/%%WINEARCH%%-windows/winehid.sys
lib/wine/%%WINEARCH%%-windows/winemapi.dll
lib/wine/%%WINEARCH%%-windows/winemenubuilder.exe