aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-10-29 22:39:09 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-12-31 18:39:20 +0000
commit6520b1cf21fbba404547c6443b835c279e7f9e3b (patch)
treed5d53a6ed50327ff63b1557310760b12411dfe4f
parent444f09a0db09c0295b8f230c2dac3da8ffcf2e7c (diff)
downloadports-6520b1cf21fbba404547c6443b835c279e7f9e3b.tar.gz
ports-6520b1cf21fbba404547c6443b835c279e7f9e3b.zip
multimedia/wlrobs: update to 1.1
-rw-r--r--multimedia/obs-studio/Makefile4
-rw-r--r--multimedia/obs-studio/distinfo2
-rw-r--r--multimedia/wlrobs/Makefile6
-rw-r--r--multimedia/wlrobs/distinfo6
-rw-r--r--multimedia/wlrobs/files/patch-meson.build6
5 files changed, 14 insertions, 10 deletions
diff --git a/multimedia/obs-studio/Makefile b/multimedia/obs-studio/Makefile
index 16fc723cbfa5..63735a36527c 100644
--- a/multimedia/obs-studio/Makefile
+++ b/multimedia/obs-studio/Makefile
@@ -1,7 +1,11 @@
PORTNAME= obs-studio
DISTVERSION= 28.1.2
+PORTREVISION= 1
CATEGORIES= multimedia
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= e221bf8eedfc.patch:-p1 # https://github.com/obsproject/obs-studio/pull/7989
+
MAINTAINER= yuri@FreeBSD.org
COMMENT= Open source streaming/recording software
WWW= https://obsproject.com/
diff --git a/multimedia/obs-studio/distinfo b/multimedia/obs-studio/distinfo
index 95485d2ce766..8e74aa504c14 100644
--- a/multimedia/obs-studio/distinfo
+++ b/multimedia/obs-studio/distinfo
@@ -27,3 +27,5 @@ SHA256 (curl-curl-44b9b4d4f56d6f6de92c89636994c03984e9cd01_GH0.tar.gz) = e3b9aa0
SIZE (curl-curl-44b9b4d4f56d6f6de92c89636994c03984e9cd01_GH0.tar.gz) = 2705576
SHA256 (akheron-jansson-bc5741fb1ac730ead24e9bd08977fc6c248e04b0_GH0.tar.gz) = a285ed51c597b23d1f25de3bc5c9c128d55c6aa17af68e0680efa028f8b0437c
SIZE (akheron-jansson-bc5741fb1ac730ead24e9bd08977fc6c248e04b0_GH0.tar.gz) = 127897
+SHA256 (e221bf8eedfc.patch) = a8c1d4614f2d019e967eb04d9214548491989c78f6df42dbbab610d3123f4eb1
+SIZE (e221bf8eedfc.patch) = 5766
diff --git a/multimedia/wlrobs/Makefile b/multimedia/wlrobs/Makefile
index 153bc8b53533..c46286b22b79 100644
--- a/multimedia/wlrobs/Makefile
+++ b/multimedia/wlrobs/Makefile
@@ -1,7 +1,6 @@
PORTNAME= wlrobs
DISTVERSIONPREFIX= v
-PORTVERSION= 1.0
-PORTREVISION= 3
+PORTVERSION= 1.1
CATEGORIES= multimedia wayland
MASTER_SITES= https://hg.sr.ht/~scoopta/${PORTNAME}/archive/${DISTVERSIONFULL:C/.*-//}${EXTRACT_SUFX}?dummy=/
@@ -16,8 +15,7 @@ BUILD_DEPENDS= cmake:devel/cmake-core
LIB_DEPENDS= libwayland-client.so:graphics/wayland \
libobs.so:multimedia/obs-studio
-USES= compiler:c11 gl meson pkgconfig
-USE_GL= egl
+USES= compiler:c11 meson pkgconfig
DATADIR= ${PREFIX}/lib/obs-plugins
PORTDATA= lib${PORTNAME}.so
diff --git a/multimedia/wlrobs/distinfo b/multimedia/wlrobs/distinfo
index 8376d9f702d7..46d8b213cfc4 100644
--- a/multimedia/wlrobs/distinfo
+++ b/multimedia/wlrobs/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1598923465
-SHA256 (wlrobs-v1.0.tar.gz) = 19a9894fc7a9854b7f17d675b48d16d5876b750aa91ebc001dcc32f68ee9cc56
-SIZE (wlrobs-v1.0.tar.gz) = 54980
+TIMESTAMP = 1667083149
+SHA256 (wlrobs-v1.1.tar.gz) = 5311c434316577b27803b272cb57011515f853705ef5d7e604ed73c483fa14be
+SIZE (wlrobs-v1.1.tar.gz) = 26920
diff --git a/multimedia/wlrobs/files/patch-meson.build b/multimedia/wlrobs/files/patch-meson.build
index c0bd3ae401b0..4559bd77b99b 100644
--- a/multimedia/wlrobs/files/patch-meson.build
+++ b/multimedia/wlrobs/files/patch-meson.build
@@ -1,13 +1,13 @@
https://github.com/obsproject/obs-studio/issues/7990
---- meson.build.orig 2020-09-01 01:24:25 UTC
+--- meson.build.orig 2022-10-29 22:39:09 UTC
+++ meson.build
-@@ -2,7 +2,7 @@ wayland = dependency('wayland-client')
+@@ -4,7 +4,7 @@ wayland = dependency('wayland-client')
inc = include_directories('inc')
wayland = dependency('wayland-client')
-obs = dependency('libobs')
+obs = dependency('libobs', method: 'cmake', modules: ['OBS::libobs'])
+ dl = cc.find_library('dl')
sources = ['src/main.c', 'proto/xdg-output-unstable-v1-protocol.c']
-