aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-10-11 23:44:45 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-10-12 00:46:23 +0000
commit6551900e74bb291302cd2866376fdc326d5f2b22 (patch)
tree56b30cec11c52ed089fcb351e7575440cce94cfb
parent31b321b68b428dda06d17c9683c66c556fcb57fa (diff)
downloadports-6551900e74bb291302cd2866376fdc326d5f2b22.tar.gz
ports-6551900e74bb291302cd2866376fdc326d5f2b22.zip
emulators/rpcs3: fails to build on FreeBSD < 13 after 31b321b68b42
ld: error: undefined symbol: std::__1::__cxx_atomic_notify_one(std::__1::__cxx_atomic_impl<long, std::__1::__cxx_atomic_base_impl<long> > const volatile*) >>> referenced by rpcn_client.cpp >>> rpcn_client.cpp.o:(rpcn::rpcn_client::rpcn_client()) in archive rpcs3/Emu/librpcs3_emu.a >>> referenced by rpcn_client.cpp >>> rpcn_client.cpp.o:(rpcn::rpcn_client::rpcn_thread()) in archive rpcs3/Emu/librpcs3_emu.a >>> referenced by rpcn_client.cpp >>> rpcn_client.cpp.o:(rpcn::rpcn_client::~rpcn_client()) in archive rpcs3/Emu/librpcs3_emu.a >>> referenced 9 more times ld: error: undefined symbol: std::__1::__libcpp_atomic_wait(std::__1::__cxx_atomic_impl<long, std::__1::__cxx_atomic_base_impl<long> > const volatile*, long) >>> referenced by rpcn_client.cpp >>> rpcn_client.cpp.o:(bool std::__1::__libcpp_thread_poll_with_backoff<std::__1::__atomic_semaphore_base::acquire()::'lambda'() const&, std::__1::__libcpp_atomic_wait_backoff_impl<std::__1::__cxx_atomic_impl<long, std::__1::__cxx_atomic_base_impl<long> >, std::__1::__atomic_semaphore_base::acquire()::'lambda'()>&>(std::__1::__atomic_semaphore_base::acquire()::'lambda'() const&, std::__1::__libcpp_atomic_wait_backoff_impl<std::__1::__cxx_atomic_impl<long, std::__1::__cxx_atomic_base_impl<long> >, std::__1::__atomic_semaphore_base::acquire()::'lambda'()>&, std::__1::chrono::duration<long long, std::__1::ratio<1l, 1000000000l> >)) in archive rpcs3/Emu/librpcs3_emu.a ld: error: undefined symbol: std::__1::__libcpp_atomic_monitor(std::__1::__cxx_atomic_impl<long, std::__1::__cxx_atomic_base_impl<long> > const volatile*) >>> referenced by rpcn_client.cpp >>> rpcn_client.cpp.o:(bool std::__1::__libcpp_thread_poll_with_backoff<std::__1::__atomic_semaphore_base::acquire()::'lambda'() const&, std::__1::__libcpp_atomic_wait_backoff_impl<std::__1::__cxx_atomic_impl<long, std::__1::__cxx_atomic_base_impl<long> >, std::__1::__atomic_semaphore_base::acquire()::'lambda'()>&>(std::__1::__atomic_semaphore_base::acquire()::'lambda'() const&, std::__1::__libcpp_atomic_wait_backoff_impl<std::__1::__cxx_atomic_impl<long, std::__1::__cxx_atomic_base_impl<long> >, std::__1::__atomic_semaphore_base::acquire()::'lambda'()>&, std::__1::chrono::duration<long long, std::__1::ratio<1l, 1000000000l> >)) in archive rpcs3/Emu/librpcs3_emu.a clang++: error: linker command failed with exit code 1 (use -v to see invocation)
-rw-r--r--emulators/rpcs3/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/emulators/rpcs3/Makefile b/emulators/rpcs3/Makefile
index ff5598afbb1c..16bb96e908f7 100644
--- a/emulators/rpcs3/Makefile
+++ b/emulators/rpcs3/Makefile
@@ -16,6 +16,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libpng.so:graphics/png \
libavcodec.so:multimedia/ffmpeg
+BROKEN_FreeBSD_12= ld: error: undefined symbol: std::__1::__cxx_atomic_notify_one
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= requires int128 and SSE2