aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2022-10-16 20:23:57 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2022-11-10 00:21:48 +0000
commit65541efda3e8345feaad76a84b2bfb37fce81f97 (patch)
tree275202e41a55c54e84dc3c77dbc47067790f573a
parentec17768330c6f896db4cdbd009162cad6560be94 (diff)
downloadports-65541efda3e8345feaad76a84b2bfb37fce81f97.tar.gz
ports-65541efda3e8345feaad76a84b2bfb37fce81f97.zip
www/varnish7: Use upstream release archive and some improvements to port
- Use upstream release archive as recommended by USE_GITHUB section in Porters Handbook - Remove USES= compiler as there's no need to modify configure script - Remove unneeded gmake and readline dependency definitions - Use USES= localbase instead of CFLAGS variable - Remove REINPLACE_CMD for GCC - Rearrange Makefile to follow Porters Handbook more closely and improve readability PR: 266467 Reviewed by: dbaio (maintainer) (cherry picked from commit efcf58c686899a38a58822afb4098b98c3d20e41)
-rw-r--r--www/varnish7/Makefile42
-rw-r--r--www/varnish7/distinfo6
2 files changed, 19 insertions, 29 deletions
diff --git a/www/varnish7/Makefile b/www/varnish7/Makefile
index 5dc94fa2d1b5..8c9ba1d313c8 100644
--- a/www/varnish7/Makefile
+++ b/www/varnish7/Makefile
@@ -1,7 +1,7 @@
PORTNAME= varnish
DISTVERSION= 7.2.0
-DISTVERSIONPREFIX= varnish-
CATEGORIES= www
+MASTER_SITES= https://varnish-cache.org/downloads/
PKGNAMESUFFIX= 7
MAINTAINER= dbaio@FreeBSD.org
@@ -15,47 +15,37 @@ BUILD_DEPENDS= rst2man:textproc/py-docutils@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sphinx>=0,1:textproc/py-sphinx@${PY_FLAVOR}
LIB_DEPENDS= libpcre2-8.so:devel/pcre2
-USES= autoreconf compiler cpe gmake libedit libtool ncurses pathfix \
- pkgconfig python:3.6+,build readline shebangfix
-
-SUB_FILES= pkg-message
-
-CONFLICTS= varnish4 varnish6
-
-SHEBANG_FILES= lib/libvcc/*.py lib/libvsc/*.py
+USES= cpe libedit libtool localbase ncurses pathfix \
+ pkgconfig python:3.6+,build shebangfix tar:tgz
CPE_VENDOR= varnish-cache
CPE_PRODUCT= varnish_cache
-CFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=${PREFIX} --without-dot
+SHEBANG_FILES= lib/libvcc/*.py lib/libvsc/*.py
USE_LDCONFIG= yes
-INSTALL_TARGET= install-strip
-TEST_TARGET= check
-TEST_ARGS= TESTS_PARALLELISM=1
+USE_RC_SUBR= varnishd varnishlog varnishncsa
+CONFLICTS= varnish4 varnish6
-USE_GITHUB= yes
-GH_ACCOUNT= varnishcache
-GH_PROJECT= varnish-cache
+SUB_FILES= pkg-message
USERS= varnish varnishlog
GROUPS= varnish
-USE_RC_SUBR= varnishd varnishlog varnishncsa
+INSTALL_TARGET= install-strip
+TEST_TARGET= check
+TEST_ARGS= TESTS_PARALLELISM=1
+
+CONFIGURE_ARGS= --localstatedir=${PREFIX} --without-dot
+
.if defined(NO_INET6) || defined(WITHOUT_INET6)
-BAD_TESTS+= r00832
-EXTRA_PATCHES+= ${FILESDIR}/no-inet6.patch
+BAD_TESTS= r00832
+EXTRA_PATCHES= ${FILESDIR}/no-inet6.patch
.endif
OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
-
post-patch:
.if defined(BAD_TESTS)
${RM} ${BAD_TESTS:C|.+|${WRKSRC}/bin/varnishtest/tests/\0.vtc|}
.endif
-.if ${CHOSEN_COMPILER_TYPE} == gcc
- ${REINPLACE_CMD} -e '/-Wno-unknown-warning-option -Wno-implicit-fallthrough/d' ${WRKSRC}/configure.ac
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/varnish7/distinfo b/www/varnish7/distinfo
index a2e0171a14e0..c3c44b3703ca 100644
--- a/www/varnish7/distinfo
+++ b/www/varnish7/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1663421158
-SHA256 (varnishcache-varnish-cache-varnish-7.2.0_GH0.tar.gz) = 7074f0c975fcc4a3cf4849b770838d0c1bbea48044e3ea1ab32d879e80df7368
-SIZE (varnishcache-varnish-cache-varnish-7.2.0_GH0.tar.gz) = 1979836
+TIMESTAMP = 1663440346
+SHA256 (varnish-7.2.0.tgz) = 1da8a97ed5f7b7d4d5e04fc5c96fc9a85cb3a20d076eba2b18951f4b306c9686
+SIZE (varnish-7.2.0.tgz) = 4018697