aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-07-06 19:16:16 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-07-06 19:20:27 +0000
commit6582c3e25c721d1c5464dea8e5c9258b09728046 (patch)
treeaca1caf0ffd7ed9b1d55268f441e7979112cd692
parentfa5d97e70c1fc73f681bf83070271ab62cff397c (diff)
downloadports-6582c3e25c721d1c5464dea8e5c9258b09728046.tar.gz
ports-6582c3e25c721d1c5464dea8e5c9258b09728046.zip
science/spheral: Update 2023.03.1 → 2023.03.2
Reported by: portscout
-rw-r--r--science/spheral/Makefile8
-rw-r--r--science/spheral/distinfo6
-rw-r--r--science/spheral/files/patch-cmake_SetupSpheral.cmake13
3 files changed, 21 insertions, 6 deletions
diff --git a/science/spheral/Makefile b/science/spheral/Makefile
index 41004dc00666..ef99246c416e 100644
--- a/science/spheral/Makefile
+++ b/science/spheral/Makefile
@@ -1,6 +1,6 @@
PORTNAME= spheral
DISTVERSIONPREFIX= v
-DISTVERSION= 2023.03.1
+DISTVERSION= 2023.03.2
CATEGORIES= science # physics
MAINTAINER= yuri@FreeBSD.org
@@ -44,9 +44,11 @@ CMAKE_ARGS= -Daneos_DIR=${LOCALBASE} \
-Dsilo_DIR=${LOCALBASE} \
-Dzlib_DIR=/usr
CMAKE_OFF= ENABLE_TESTS ENABLE_DOCS \
- ENABLE_ANEOS
+ ENABLE_ANEOS \
+ ENABLE_CUDA
CMAKE_ON= ENABLE_CXXONLY # disable Python support which is still for Python-2.7, see https://github.com/LLNL/spheral/issues/183
-CMAKE_TESTING_ON= ENABLE_TESTS # tests fail to configure, see https://github.com/LLNL/spheral/issues/207
+CMAKE_ON+= ENABLE_OPENMP
+CMAKE_TESTING_ON= ENABLE_TESTS # tests fail to build, see https://github.com/LLNL/spheral/issues/230
CXXFLAGS+= -I${LOCALBASE}/include/eigen3
diff --git a/science/spheral/distinfo b/science/spheral/distinfo
index b8a1df491c20..62485e8f4e68 100644
--- a/science/spheral/distinfo
+++ b/science/spheral/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1687453540
-SHA256 (LLNL-spheral-v2023.03.1_GH0.tar.gz) = a4e818fdb7d5d1fa9b67247ef2a0e5b80f3346a87da166112a4b1944f79df211
-SIZE (LLNL-spheral-v2023.03.1_GH0.tar.gz) = 6652948
+TIMESTAMP = 1688627887
+SHA256 (LLNL-spheral-v2023.03.2_GH0.tar.gz) = 1f20c382d86dfdeed8bce338ef54bc5b855315adac37f52dd42412d630eeab56
+SIZE (LLNL-spheral-v2023.03.2_GH0.tar.gz) = 6653174
SHA256 (llnl-blt-ddd5a0c_GH0.tar.gz) = 5c235a9b160f1cc3f6ce4d7c80bf72772ac10839909f4f96075d08b3edd8f540
SIZE (llnl-blt-ddd5a0c_GH0.tar.gz) = 1220052
SHA256 (llnl-uberenv-126f8de_GH0.tar.gz) = 6a403e722dc023d87dd69f8235fa631ab96a7b1ff328929b9c969e7c113ce9f7
diff --git a/science/spheral/files/patch-cmake_SetupSpheral.cmake b/science/spheral/files/patch-cmake_SetupSpheral.cmake
new file mode 100644
index 000000000000..12531e31d4b8
--- /dev/null
+++ b/science/spheral/files/patch-cmake_SetupSpheral.cmake
@@ -0,0 +1,13 @@
+- eliminate the need to use git
+
+--- cmake/SetupSpheral.cmake.orig 2023-07-06 16:44:17 UTC
++++ cmake/SetupSpheral.cmake
+@@ -176,7 +176,7 @@ if (ENABLE_TESTS)
+
+ # Find the test files we want to install
+ execute_process(
+- COMMAND git ls-files tests
++ COMMAND find tests -type f
+ WORKING_DIRECTORY ${SPHERAL_ROOT_DIR}
+ OUTPUT_VARIABLE test_files1)
+ string(REPLACE "\n" " " test_files ${test_files1})