aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-06-03 23:50:59 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-06-04 00:34:49 +0000
commit65de78bb21359541eee15f9f045e2124b3cf4b60 (patch)
treef3f4c2c087048e0763a338001c5b497d031fbad3
parent74ca63e502fbf210da719e03b12161b2540e2685 (diff)
downloadports-65de78bb21359541eee15f9f045e2124b3cf4b60.tar.gz
ports-65de78bb21359541eee15f9f045e2124b3cf4b60.zip
devel/py-apscheduler: convert to USE_PYTHON=pytest
-rw-r--r--devel/py-apscheduler/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/devel/py-apscheduler/Makefile b/devel/py-apscheduler/Makefile
index b8578e22e034..c9a354edd9d6 100644
--- a/devel/py-apscheduler/Makefile
+++ b/devel/py-apscheduler/Makefile
@@ -15,16 +15,12 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@$
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.4.0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tzlocal>=1.2<3:devel/py-tzlocal@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-asyncio>0:devel/py-pytest-asyncio@${PY_FLAVOR} \
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-asyncio>0:devel/py-pytest-asyncio@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-tornado>0:devel/py-pytest-tornado@${PY_FLAVOR}
NO_ARCH= yes
USES= python:3.6+
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist distutils pytest
TEST_ENV= ${MAKE_ENV} TZ=UTC
-do-test:
- @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest)
-
.include <bsd.port.mk>