aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2024-02-12 13:24:05 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2024-02-18 11:51:39 +0000
commit664008c67911f77ea347e9dc4f3b888160785fd9 (patch)
tree1308105f957c6a092b6bb2399f4dd607a5d98763
parentad10c20b45651a8c110d5b07657d50828b5d8f15 (diff)
downloadports-664008c67911f77ea347e9dc4f3b888160785fd9.tar.gz
ports-664008c67911f77ea347e9dc4f3b888160785fd9.zip
www/py-flower: New port
Celery flower - monitor and manage Celery clusters
-rw-r--r--www/Makefile1
-rw-r--r--www/py-flower/Makefile33
-rw-r--r--www/py-flower/distinfo3
-rw-r--r--www/py-flower/pkg-descr3
4 files changed, 40 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 24bfe2531efe..a842e9b8f345 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1666,6 +1666,7 @@
SUBDIR += py-flask-sockets
SUBDIR += py-flask-uploads
SUBDIR += py-flask-wtf
+ SUBDIR += py-flower
SUBDIR += py-flup6
SUBDIR += py-folium
SUBDIR += py-forcediphttpsadapter
diff --git a/www/py-flower/Makefile b/www/py-flower/Makefile
new file mode 100644
index 000000000000..8cce8cd3741d
--- /dev/null
+++ b/www/py-flower/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= flower
+PORTVERSION= 2.0.1
+CATEGORIES= www python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= grembo@FreeBSD.org
+COMMENT= Celery flower - monitor and manage Celery clusters
+WWW= https://github.com/mher/flower
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}celery>=5.3.6:devel/py-celery@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}humanize>=4.2.1:devel/py-humanize@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}prometheus-client>=0.17.1:net-mgmt/py-prometheus-client@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tornado>=6.3.3:www/py-tornado@${PY_FLAVOR}
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=2.8.2:devel/py-dateutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+TEST_ENV= PYTHONPATH=${WRKSRC}/src
+
+NO_ARCH= yes
+
+do-test:
+ cd ${WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest -v -rs -o addopts=
+
+.include <bsd.port.mk>
diff --git a/www/py-flower/distinfo b/www/py-flower/distinfo
new file mode 100644
index 000000000000..608ba5fbd24c
--- /dev/null
+++ b/www/py-flower/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1707648242
+SHA256 (flower-2.0.1.tar.gz) = 5ab717b979530770c16afb48b50d2a98d23c3e9fe39851dcf6bc4d01845a02a0
+SIZE (flower-2.0.1.tar.gz) = 3220408
diff --git a/www/py-flower/pkg-descr b/www/py-flower/pkg-descr
new file mode 100644
index 000000000000..8ea49550f369
--- /dev/null
+++ b/www/py-flower/pkg-descr
@@ -0,0 +1,3 @@
+Flower is an open-source web application for monitoring and managing Celery
+clusters. It provides real-time information about the status of Celery
+workers and tasks.