aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-10-03 02:17:46 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-10-03 02:17:46 +0000
commit66981490ac92d9c7c93ab6d5c469cac58bc11c5c (patch)
treec069f8bd4ee77e5cfe7b08d596c9e846de3e1665
parent6879948fdb161d08115bdbd4916fde6625c8928b (diff)
downloadports-66981490ac92d9c7c93ab6d5c469cac58bc11c5c.tar.gz
ports-66981490ac92d9c7c93ab6d5c469cac58bc11c5c.zip
devel/py-nbformat: Update to 5.5.0
-rw-r--r--devel/py-nbformat/Makefile5
-rw-r--r--devel/py-nbformat/distinfo6
-rw-r--r--devel/py-nbformat/files/setup.py40
3 files changed, 47 insertions, 4 deletions
diff --git a/devel/py-nbformat/Makefile b/devel/py-nbformat/Makefile
index 239c93327fb8..54b6f43e0da9 100644
--- a/devel/py-nbformat/Makefile
+++ b/devel/py-nbformat/Makefile
@@ -1,5 +1,5 @@
PORTNAME= nbformat
-PORTVERSION= 5.4.0
+PORTVERSION= 5.5.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -24,4 +24,7 @@ USE_PYTHON= autoplist concurrent distutils pytest
NO_ARCH= yes
+post-patch:
+ @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
+
.include <bsd.port.mk>
diff --git a/devel/py-nbformat/distinfo b/devel/py-nbformat/distinfo
index bf25ac149be9..29815b2d7de2 100644
--- a/devel/py-nbformat/distinfo
+++ b/devel/py-nbformat/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1652122931
-SHA256 (nbformat-5.4.0.tar.gz) = 44ba5ca6acb80c5d5a500f1e5b83ede8cbe364d5a495c4c8cf60aaf1ba656501
-SIZE (nbformat-5.4.0.tar.gz) = 137589
+TIMESTAMP = 1663673074
+SHA256 (nbformat-5.5.0.tar.gz) = 9ebe30e6c3b3e5b47d39ff0a3897a1acf523d2bfafcb4e2d04cdb70f8a66c507
+SIZE (nbformat-5.5.0.tar.gz) = 141188
diff --git a/devel/py-nbformat/files/setup.py b/devel/py-nbformat/files/setup.py
new file mode 100644
index 000000000000..f11243529652
--- /dev/null
+++ b/devel/py-nbformat/files/setup.py
@@ -0,0 +1,40 @@
+#!/usr/bin/env python
+# setup.py generated by flit for tools that don't yet use PEP 517
+
+from distutils.core import setup
+
+packages = \
+['nbformat',
+ 'nbformat.corpus',
+ 'nbformat.corpus.tests',
+ 'nbformat.v1',
+ 'nbformat.v2',
+ 'nbformat.v3',
+ 'nbformat.v4']
+
+package_data = \
+{'': ['*']}
+
+install_requires = \
+['fastjsonschema', 'jsonschema>=2.6', 'jupyter_core', 'traitlets>=5.1']
+
+extras_require = \
+{'test': ['check-manifest', 'testpath', 'pytest', 'pre-commit', 'pep440']}
+
+entry_points = \
+{'console_scripts': ['jupyter-trust = '
+ 'nbformat.sign:TrustNotebookApp.launch_instance']}
+
+setup(name='nbformat',
+ version='%%PORTVERSION%%',
+ description='The Jupyter Notebook format',
+ author=None,
+ author_email='Jupyter Development Team <jupyter@googlegroups.com>',
+ url=None,
+ packages=packages,
+ package_data=package_data,
+ install_requires=install_requires,
+ extras_require=extras_require,
+ entry_points=entry_points,
+ python_requires='>=3.7',
+ )