aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-08-12 22:11:28 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-01-01 05:37:33 +0000
commit66a56680940cb215d218629178318dd2fe241b06 (patch)
tree128ae177628e5ba05cd7e5450ea4ddaef2607b23
parent8c1e3e605452d8181b2180dad180679d93aecbe3 (diff)
downloadports-66a56680940cb215d218629178318dd2fe241b06.tar.gz
ports-66a56680940cb215d218629178318dd2fe241b06.zip
astro/mepo: update to 1.2.0
Changes: https://git.sr.ht/~mil/mepo/refs/1.2.0 Reported by: Repology
-rw-r--r--astro/mepo/Makefile10
-rw-r--r--astro/mepo/distinfo6
-rw-r--r--astro/mepo/files/patch-src_api_bind__signal.zig25
3 files changed, 6 insertions, 35 deletions
diff --git a/astro/mepo/Makefile b/astro/mepo/Makefile
index dc418988f731..b797aca00aa1 100644
--- a/astro/mepo/Makefile
+++ b/astro/mepo/Makefile
@@ -1,6 +1,5 @@
PORTNAME= mepo
-DISTVERSION= 1.1.2
-PORTREVISION= 1
+DISTVERSION= 1.2.0
CATEGORIES= astro geography wayland
MASTER_SITES= https://git.sr.ht/~mil/${PORTNAME}/archive/${DISTVERSIONFULL}${EXTRACT_SUFX}?dummy=/
@@ -12,7 +11,7 @@ LICENSE= GPLv3+ OFL11
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= zig010>=0.10.0:lang/zig010
+BUILD_DEPENDS= zig>=0.11.0:lang/zig
LIB_DEPENDS= libcurl.so:ftp/curl
RUN_DEPENDS= jq:textproc/jq
@@ -23,14 +22,11 @@ SHEBANG_LANG= sh
sh_CMD= /bin/sh
MAKE_ENV= DESTDIR="${STAGEDIR}"
CONFIGURE_ARGS= --prefix "${PREFIX}" \
- ${WITH_DEBUG:D:U-Drelease-fast} \
+ ${WITH_DEBUG:D:U-Doptimize=ReleaseFast} \
-Dcpu=${CPUTYPE:Ubaseline} \
--verbose
NO_INSTALL= yes # strip(1) breaks runtime
-# https://github.com/ziglang/zig/issues/12170 (SDL2, curl)
-MAKE_ENV+= PKG_CONFIG_SYSTEM_LIBRARY_PATH="${LOCALBASE}/lib"
-
post-patch:
@${REINPLACE_CMD} -e 's,/usr,${LOCALBASE},' \
${WRKSRC}/scripts/mepo_ui_menu_user_pin_updater.sh
diff --git a/astro/mepo/distinfo b/astro/mepo/distinfo
index 7ddbdd7214d6..0e364bdbf774 100644
--- a/astro/mepo/distinfo
+++ b/astro/mepo/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1675222988
-SHA256 (mepo-1.1.2.tar.gz) = d2dd93988fc75964715051720cbc30b6c2b8646812b508fa4e25495fbe33b284
-SIZE (mepo-1.1.2.tar.gz) = 590350
+TIMESTAMP = 1691878288
+SHA256 (mepo-1.2.0.tar.gz) = 760986c551c3f9be4addb3d8d698b658695bbadb04e6b96c8b3e6a9177b46ded
+SIZE (mepo-1.2.0.tar.gz) = 592505
diff --git a/astro/mepo/files/patch-src_api_bind__signal.zig b/astro/mepo/files/patch-src_api_bind__signal.zig
deleted file mode 100644
index 378d281adc74..000000000000
--- a/astro/mepo/files/patch-src_api_bind__signal.zig
+++ /dev/null
@@ -1,25 +0,0 @@
-https://lists.sr.ht/~mil/mepo-devel/patches/38775
-
---- src/api/bind_signal.zig.orig 2023-02-01 03:43:08 UTC
-+++ src/api/bind_signal.zig
-@@ -39,13 +39,14 @@ fn bind_signal(mepo: *Mepo, signo_str: [:0]const u8, expression: []const u8) !vo
- }
-
- // Register generic signal handler
-- if (0 != std.os.linux.sigaction(signal_name, &.{
-+ const signal_action = std.os.Sigaction{
- .handler = .{ .handler = utilsdl.sdl_push_event_signal },
-- .mask = [_]u32{0} ** 32,
-- .flags = @as(c_uint, 0),
-- }, null)) {
-- return error.FailedToSetupSighandler;
-- }
-+ .mask = std.os.empty_sigset,
-+ .flags = 0,
-+ };
-+
-+ std.os.sigaction(signal_name, &signal_action, null)
-+ catch return error.FailedToSetupSighandler;
-
- if (mepo.table_signals.get(signal_name)) |heap_str| {
- mepo.allocator.free(heap_str);