aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2024-06-29 23:06:57 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2024-06-29 23:08:58 +0000
commit66ae4f88bcf7ffc77c623d3805567c8e3bc1b69a (patch)
tree95351092e3865a898e156a71866b0964c82250d1
parent88e8cfd6a8cbf50bde8564ee4fa047816c978b7a (diff)
downloadports-66ae4f88bcf7ffc77c623d3805567c8e3bc1b69a.tar.gz
ports-66ae4f88bcf7ffc77c623d3805567c8e3bc1b69a.zip
graphics/cegui: add patch to fix upcomming libxml2 update
PR: 279965
-rw-r--r--graphics/cegui/files/patch-cegui__src__CMakeLists.txt4
-rw-r--r--graphics/cegui/files/patch-cegui_src_XMLParserModules_Libxml2_XMLParser.cpp14
2 files changed, 16 insertions, 2 deletions
diff --git a/graphics/cegui/files/patch-cegui__src__CMakeLists.txt b/graphics/cegui/files/patch-cegui__src__CMakeLists.txt
index de36d8f4e4c0..4b88c991b163 100644
--- a/graphics/cegui/files/patch-cegui__src__CMakeLists.txt
+++ b/graphics/cegui/files/patch-cegui__src__CMakeLists.txt
@@ -1,6 +1,6 @@
---- cegui/src/CMakeLists.txt.orig 2014-07-07 07:06:18 UTC
+--- cegui/src/CMakeLists.txt.orig 2016-04-23 18:19:40 UTC
+++ cegui/src/CMakeLists.txt
-@@ -93,6 +93,10 @@ elseif (MINGW)
+@@ -99,6 +99,10 @@ elseif (MINGW)
cegui_target_link_libraries(${CEGUI_TARGET_NAME} ${CMAKE_DL_LIBS})
endif()
diff --git a/graphics/cegui/files/patch-cegui_src_XMLParserModules_Libxml2_XMLParser.cpp b/graphics/cegui/files/patch-cegui_src_XMLParserModules_Libxml2_XMLParser.cpp
new file mode 100644
index 000000000000..c767f5abd03d
--- /dev/null
+++ b/graphics/cegui/files/patch-cegui_src_XMLParserModules_Libxml2_XMLParser.cpp
@@ -0,0 +1,14 @@
+--- cegui/src/XMLParserModules/Libxml2/XMLParser.cpp.orig 2016-04-23 18:19:40 UTC
++++ cegui/src/XMLParserModules/Libxml2/XMLParser.cpp
+@@ -99,7 +99,11 @@ void LibxmlParser::parseXML(XMLHandler& handler,
+
+ if (!doc)
+ {
++#if LIBXML_VERSION >= 21200
++ const xmlError* err = xmlGetLastError();
++#else
+ xmlError* err = xmlGetLastError();
++#endif
+
+ CEGUI_THROW(GenericException(
+ String("xmlParseMemory failed in file: '") +