aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:01:10 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:01:10 +0000
commit66da2e249cde4a8b680854c0ebd1fe8f45334c75 (patch)
tree9ebccd5cabe1bda992b3d768e450058e56dd333b
parentc9009e0e6372a50aa0586b68d6942e348d7272ab (diff)
downloadports-66da2e249cde4a8b680854c0ebd1fe8f45334c75.tar.gz
ports-66da2e249cde4a8b680854c0ebd1fe8f45334c75.zip
devel/py-xstatic-jquery-migrate: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--devel/py-xstatic-jquery-migrate/Makefile7
-rw-r--r--devel/py-xstatic-jquery-migrate/files/patch-setup.py11
2 files changed, 16 insertions, 2 deletions
diff --git a/devel/py-xstatic-jquery-migrate/Makefile b/devel/py-xstatic-jquery-migrate/Makefile
index a4e03dbc86bc..dd0ab2766e5a 100644
--- a/devel/py-xstatic-jquery-migrate/Makefile
+++ b/devel/py-xstatic-jquery-migrate/Makefile
@@ -1,6 +1,6 @@
PORTNAME= xstatic-jquery-migrate
PORTVERSION= 3.3.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,8 +13,11 @@ WWW= https://github.com/openstack/xstatic-jquery-migrate \
LICENSE= MIT
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/devel/py-xstatic-jquery-migrate/files/patch-setup.py b/devel/py-xstatic-jquery-migrate/files/patch-setup.py
new file mode 100644
index 000000000000..ae684bfc13cd
--- /dev/null
+++ b/devel/py-xstatic-jquery-migrate/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2021-01-27 16:16:26 UTC
++++ setup.py
+@@ -7,7 +7,7 @@ setup(
+ from setuptools import setup, find_packages
+
+ setup(
+- name=xs.PACKAGE_NAME,
++ name='xstatic-jquery-migrate',
+ version=xs.PACKAGE_VERSION,
+ description=xs.DESCRIPTION,
+ long_description=long_description,