aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-12-21 06:46:28 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-12-21 06:46:28 +0000
commit67036fa73cb553fd38fe589e2ca8896ef623090c (patch)
treee1d760447535efab870aa9a5f506c1a71dbf8b10
parent9f774d41c99b4751fc9aafc428b61d944ce40da4 (diff)
downloadports-67036fa73cb553fd38fe589e2ca8896ef623090c.tar.gz
ports-67036fa73cb553fd38fe589e2ca8896ef623090c.zip
graphics/librtprocess: new port had been added (+)
This project aims to make some of RawTherapee's highly optimized raw processing routines readily available for other photo editing software. The goal is to move certain source files from RawTherapee into this library. Thus, any changes to the source can be done here and will be used by the projects which use librtprocess. WWW: https://github.com/CarVac/librtprocess
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/librtprocess/Makefile21
-rw-r--r--graphics/librtprocess/distinfo3
-rw-r--r--graphics/librtprocess/pkg-descr8
-rw-r--r--graphics/librtprocess/pkg-plist8
5 files changed, 41 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 8038dba8ac13..389b96cf75bc 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -493,6 +493,7 @@
SUBDIR += libreatlas
SUBDIR += librsvg2
SUBDIR += librsvg2-rust
+ SUBDIR += librtprocess
SUBDIR += libsixel
SUBDIR += libspiro
SUBDIR += libspng
diff --git a/graphics/librtprocess/Makefile b/graphics/librtprocess/Makefile
new file mode 100644
index 000000000000..f59ce78f16ac
--- /dev/null
+++ b/graphics/librtprocess/Makefile
@@ -0,0 +1,21 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+
+PORTNAME= librtprocess
+PORTVERSION= 0.11.0
+CATEGORIES= graphics
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Library for raw image processing
+
+LICENSE= GPLv3+
+
+USES= cmake
+USE_GITHUB= yes
+GH_ACCOUNT= CarVac
+USE_LDCONFIG= yes
+
+.if !defined(WITH_DEBUG)
+CXXFLAGS+= -DNDEBUG
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/librtprocess/distinfo b/graphics/librtprocess/distinfo
new file mode 100644
index 000000000000..7a27c8bdedcc
--- /dev/null
+++ b/graphics/librtprocess/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1586386847
+SHA256 (CarVac-librtprocess-0.11.0_GH0.tar.gz) = 0a1691e6e90742644506a1123c716cdcfc28689adf461747843ab0440a837584
+SIZE (CarVac-librtprocess-0.11.0_GH0.tar.gz) = 157473
diff --git a/graphics/librtprocess/pkg-descr b/graphics/librtprocess/pkg-descr
new file mode 100644
index 000000000000..023623b73651
--- /dev/null
+++ b/graphics/librtprocess/pkg-descr
@@ -0,0 +1,8 @@
+This project aims to make some of RawTherapee's highly optimized raw
+processing routines readily available for other photo editing software.
+
+The goal is to move certain source files from RawTherapee into this
+library. Thus, any changes to the source can be done here and will be
+used by the projects which use librtprocess.
+
+WWW: https://github.com/CarVac/librtprocess
diff --git a/graphics/librtprocess/pkg-plist b/graphics/librtprocess/pkg-plist
new file mode 100644
index 000000000000..d040a910c0c6
--- /dev/null
+++ b/graphics/librtprocess/pkg-plist
@@ -0,0 +1,8 @@
+include/rtprocess/librtprocess.h
+lib/cmake/rtprocess/rtprocess-config-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/rtprocess/rtprocess-config-version.cmake
+lib/cmake/rtprocess/rtprocess-config.cmake
+lib/librtprocess.so
+lib/librtprocess.so.0
+lib/librtprocess.so.0.0.1
+libdata/pkgconfig/rtprocess.pc